Support » Installing WordPress » Database Upgrade Required: Not Working (WP 2.9)

  • Hello. Longtime (5 years) user of WordPress on all of my domains. I went to upgrade to the new 2.9 version this evening and it worked fine, as always. When complete, a screen told me:

    Database Upgrade Required

    WordPress has been updated! Before we send you on your way, we have to upgrade your database to the newest version.

    The upgrade process may take a little while, so please be patient.

    Upgrade WordPress Database

    When I click on the button, it works for a moment and then sits on a WordPress logo with nothing else. I can now not log into my domain b/c it brings me back to this page!

    How can I rectify this situation?

Viewing 15 replies - 1 through 15 (of 40 total)
  • I have this problem as well. Any solutions yet?

    I got this error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 524288 bytes) in /home2/…/wp-db.php on line 734

    @truth – You might need to increase the memory size in your php.ini file or ask your host to do it.

    You will have to change the value for php_value memory_limit in your php.ini. You can Google for the same to find more info.

    @wpwend42 – You might be facing the same problems as @truth, however your browser might be setup to not display real errors, try to change that setting. Alternatively, check the error log file of your web server to see if there are any errors.

    I just manage to do a rollback. I don’t think I’ll be doing the upgrade any time soon till someone manage to upgrade it successfully. Seems like there are quite a number of errors around.

    Thanks though!

    I tried doing an auto-upgrade and had a database fail with a huge list of errors all which start with “WordPress database error: [MySQL server has gone away]”, but at the bottom of the list is the button that says your update was successful. Click on it and it brings you back to the “You must update your database page again.

    I restored back to WP 2.86 and my data was okay. I then did a manual update of 2.9 and I got the same result as the auto-update.

    I looked at my server error log … OMG …. what a mess! I have t call my ISP to see what they can make of it. I’m reverting back to 2.86 & crossing my fingers.

    My host increased the memory limit to 50GB but I still couldn’t upgrade my database. Help please? 🙁

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    I don’t think I’ll be doing the upgrade any time soon till someone manage to upgrade it successfully. Seems like there are quite a number of errors around.

    Upgraded 5 this morning without any problems. But then again, my backup safety net is pretty iron clad…

    @truth, congrats on the rollback, too many users don’t keep good backups.

    I think you meant 50MB but let’s see if we can do some checking.

    Can you create this short file in your installation?

    <?php
    phpinfo();
    ?>

    Save it as wp-content/phpinfo.php afterwards delete it if you want to.

    Now in your browser load up http://your-blog-url/wp-content/phpinfo.php and look for the line that reads memory_limit. Mine says 64M, yours should read 50M.

    Now check the Mysql version. On that same page look for Client API version which is under the mysql section. If that reads 5.0 something, then we can rule out the mysql version.

    I’m asking this to make sure you can rule out memory limits and mysql version problems.

    I had the exact same problem than wpwend42. I followed jalmz link : http://www.clickonf5.org/wordpress/solution-database-upgrade-required/2247.

    My problem was indeed that the Option_Value for the Option_Name db_version was ‘11548’ instead of ‘12329’ (http://codex.wordpress.org/Version_2.9).

    I changed it with phpmyadmin, and I recovered my brand new 2.9 wordpress blog.

    Thanks jdembowski for the help!

    I have found a way to upgrade successfully.

    I did a rollback to 2.8.6.
    Deactivate all the plugins.
    Did a automatic upgrade to 2.9.
    This time no database upgrade is required.
    Activate all the plugins again and it’s working!

    Thank you 🙂

    12329 was the problem! Thanks!

    O.K glad to see I was not the only one with this problem.

    Indeed changing the database version allows wp to run fine again. Or appear to?

    Does this break anything. Does the database really need to be upgraded?

    This should be fixed and releases should not be released until these bugs have been worked out. I can’t access two of my blogs now thanks to this problem and nothing I have found here is working. Why don’t you developers stop trying to release new versions so quickly? Just let us bloggers be for awhile, without all these upgrades. We don’t need constant upgrades.

    I’m really tired of having to fix problems like this that we should never have to deal with.

    I had a problem with identical symptoms – the database upgrade would hang after a certain point. I looked into the code and found that it was the function pre_schema_upgrade() that was hanging. Specifically the MySQL statement:

    SELECT o1.option_id FROM $wpdb->options AS o1 JOIN $wpdb->options AS o2 ON o2.option_name = o1.option_name AND o2.option_id > o1.option_id

    (line 1685 of wp-admin/includes/upgrade.php)

    The upgrade code is looking for duplicated entries in the options database table to remove.

    When I ran that request in phpAdmin I got a result with 6 million lines, whereas there were only 400 odd lines with distinct option_name values. I added the work distinct after SELECT on that line forcing it to remove duplicate results. That seemed to work and allowed the upgrade to proceed as usual.

    For what it’s worth, I have been having the same problem as Truth. I am backedup and could rollback but am concerned about my skills not being good enough to do this successfully.

    That said, here’s what I’m seeing after I upgraded to 2.9. For social bookmark plugins, when they’re activated, I’m getting:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /myblog/public_html/wp-includes/kses.php(413) : runtime-created function on line 1

    When I deactivate this one…
    Social Bookmarks 4.1.3
    http://www.dountsis.com/projects/social-bookmarks/

    or deactivate this one
    Social Bookmarking Reloaded 3.02
    http://www.valent-blog.eu/social-bookmarking-reloaded/

    They both produce the same error when I try to edit one a page.

    OK.. I fixed it via my hosting company and increasing memory_limit to 128 MB in php.ini

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘Database Upgrade Required: Not Working (WP 2.9)’ is closed to new replies.