Support » Fixing WordPress » Database Update Required

Viewing 15 replies - 1 through 15 (of 23 total)
  • Try:
    – switching to the Twenty Twelve theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    – running the upgrade manually via wp-admin/upgrade.php

    Now I get Internal Server Error. Sigh.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 35 bytes) in /home/content/74/9126574/html/wp-includes/wp-db.php on line 1220

    Warren

    (@rabbitwordpress)

    Hi Guys,

    I just experienced the same problem and managed to fix it successfully. It seemed the database on my clients site had bloated to 123mb, which is probably too close to the default limit set in wp-config.php

    This is what I did :
    1) Increased the memory limit in wp-config.php (in your site root/base) to 228mb by changing

    define(‘WP_MEMORY_LIMIT’, ‘128M’);
    to
    define(‘WP_MEMORY_LIMIT’, ‘228M’);

    2) Then go back to http://www.yoursite.com/wp-admin/ and click update, it should take a little longer this time and then eventually take you to http://www.yoursite.com/wp-login.php where you should now be able to login as normal.

    3) To stop this happening again next time, you will need to clear out your post “Revisions” to reduce the size of your database. To do this login to phpmyadmin and run the following SQL query DELETE FROM wp_posts WHERE post_type = “revision”; which should take less than a few seconds to run.

    Note: Don’t forget to backup your database before and after you run this query. My first backup was 123mb, the second was 29mb!! So quite a saving hey.

    4) Now FTP into your site and go to :
    wp-includes/default-constants.php
    Go to line 279 and change :
    define(‘WP_POST_REVISIONS’, true);
    to
    define(‘WP_POST_REVISIONS’, 3);

    Note: You could choose a higher number of revisions if you like but I really think 3 is enough.

    5) Finally go back to wp-config.php and drop WP_MEMORY_LIMIT back down to 128mb

    My site works again perfectly!

    Hope this helps!
    Cheers
    Warren

    THANK YOU WARREN!!! That worked perfectly!!!

    danceadvantage

    (@danceadvantage)

    THANK YOU!!!! This happened to me during the recent update.

    I’m having the same problem & Im not very html & wordpress savvy, so I don’t understand the above solution.
    Ive found the said wp-config.php file and opened it in text edit. I can’t locate any part which reads ‘WP_MEMORY_LIMIT’, ‘128M’.
    IS there an easier way to solve this problem? Every time i click on my website it won’t let me passed the page, ‘Database Update Required’. If i uninstall and reinstall will this rectify it. I’m looking for the simplest fix.
    thanks in advance
    CF

    Warren

    (@rabbitwordpress)

    Hi Cuckoofilms,
    This has moved since version 3.0 to :
    wp-includes/default-constants.php
    line 23:
    define(‘WP_MEMORY_LIMIT’, ’40M’);

    temporarily change to 40M to 128M

    Hope that helps!

    thanks for your help. However I’m having trouble locating the exact file above. Will it resolve if I uninstall and reinstall? or will I loose my site?

    I’ve located the file and changed to 128m. still no joy. Ive noticed in the http address bar it adds ‘upgrade.php’ see below..
    http://www.cuckoofilms.co.uk/blog/wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2Fwp-admin%2Fpost.php%3Fpost%3D125%26action%3Dedit

    is there a way i can get rid of the upgrade. I was happy before anyway.
    cheers
    CF

    You should always keep WordPress updated. Failing to do so may result in your site being hacked. I’d suggest contacting your hosts about the memory issue.

    Warren

    (@rabbitwordpress)

    Hi Cuckoofilms, sorry to hear you had no success! I just checked the link and yes I can see you still have the message.

    After clicking “Update” your site site seems to be ok. I can see your site front http://www.cuckoofilms.co.uk/blog/ and login page page yoursite (slash) blog (slash) wp-login.php

    Are you saying that when you try to login you get the message back?

    thanks for your reply. The site is still running but when I click ‘edit page’ it keeps taking me to the 2 pages <Database Update Required>, I then click on it and it takes me to
    <Your WordPress database has been successfully updated!> i click <continue> and it takes me back on a loop to <Database Update Required>.
    Will I loose my site if I uninstall and reinstall? It seems to be the only option.
    thanks again

    Warren

    (@rabbitwordpress)

    Hi Cuckoofilms, reinstalling your site is unlikely to fix the problem unless you start from scratch which will obvious cause you to loose everything.

    You might first want to try turning off all your plugins by renaming your /wp-content/plugins to /wp-content/plugins.hold

    Source : http://codex.wordpress.org/FAQ_Troubleshooting

    Then try again, if that works then you know its an issue with one of your plugins.

    I can see your on a 123 Reg server, I have a few sites with them too and apart from being slow they’re usually quite reliable so its unlikely to be a problem with your WordPress system files as such.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Database Update Required’ is closed to new replies.