Database Update Required (5 posts)

  1. Chipsey
    Posted 4 years ago #

    When I try to log in it asks me to update database, and then I get the error message:

    Fatal error: Class 'WP_Theme' not found in /home/chipsey/public_html/teddingtonfitness.com/wp-includes/theme.php on line 106

    Please help!

  2. Tara
    Volunteer Moderator
    Posted 4 years ago #

    Have you tried:

    -deactivating ALL plugins (yes, all) temporarily to narrow down the problem. If the problem goes away, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive). If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    -switching to the unedited default theme (Twenty Eleven) for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.
    If you don't have access to your admin area, then access your server via FTP or SFTP or whatever file management application your host provides.

    -If the above troubleshooting steps do not resolve the issue, try manually re-upload all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory. Read the Manual Update directions first!

  3. StandardExcellence
    Posted 3 years ago #

    I'm having the same problem, except I'm pretty sure I've caused my own issues by doing to many things to list here. Bottom line is I know my database is intact because I can access it from the back end, and was able to access my admin panel with the correct info previously.

    The same error is what I get when trying to log in for the "first" time. I put it in quotes because now I'm on the n-teenth attempt, but it's still at the same step. I've renamed my plugins folder, manually removed a cache plugin (and associated files), and removed other themes.

    The only thing I lack suggested by t-p is uploading all but wp-config. I've already re-uploaded the other wp- directories to no avail. Just adding some notes in case anyone else runs into this.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Please post a new topic.

  5. StandardExcellence
    Posted 3 years ago #

    My apologies, just meant to add notes to the current topic. My issue has been resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.