Support » Fixing WordPress » Database Update Loop

  • Resolved MisterQ


    OK, I have looked and there are several discussions of this, but non matches my circumstances, and non provides a definitive answer or explanation.

    I have put a brand new virgin installation of 3.8.1 on a domain that I am hosting on

    Attempts to change anything in the wordpress control panels Takes me into the “Database Update Required” screen, when I select “Update WordPress Database” – it comes back with the “NO update required” and around in circles. What is wrong here…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Is it a browser cache problem? could you try clearing your cache or trying using a different browser?

    I have tried this again – fresh installs of 3.9 for two sites – both hosted on the same server. One works fine – the second one is regularly getting the “Database Update Required”. I try flushing browser cache, and browser history, to no avail.

    I am also seeing sometimes when I am doing something – like adding an image to the “media” it prompts me for a username and password (underneath the image “drop it here” section, that doesn’t accept my default username and password, and the only way to get bank in is to go back to the “top” of the site.

    Are the file permissions correct on your server, usually the username password prompts are due to that. You can learn more about the file permissions here. I believe you are logged in as an administrator as well. Also please check if the user account which owns the WordPress process on the server has appropriate permissions to update and modify files.

    Actually, I think I have found the cause of the problem. I am hosting on mediatemple and one of the server level options is the PHP version/support. I noticed that the settings were different between the site that worked and the site that didn’t.

    The Options are PHP 5.3.27 (CGI) (stable) or PHP 5.3.27 (FastCGI) or PHP 5.5.6 CGI (latest). It was breaking under the FastCGI Version, but works fine under the Stable Version…

    I will check the permissions as well, just to be sure.

    Interesting to know that. Do keep us updated if FastCGI indeed was the reason for the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Database Update Loop’ is closed to new replies.