[resolved] Database update fails after update to 3.5.2 (5 posts)

  1. johanna2patricia
    Posted 2 years ago #

    Hi everybody,
    I just updated my blog to 3.5.2 and when I try to get to my admin panel, I land on the page which requests me to update the database: "Database Update Required
    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.
    The update process may take a little while, so please be patient."

    When I do that I get this error:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 72 bytes) in /data/home/patr01/domains/patriciakaas.nl/public_html/blog/wp-includes/wp-db.php on line 1438

    I uploaded a phpinfo.php and I see that the memory limit is 128m.
    What can I do?


  2. johanna2patricia
    Posted 2 years ago #

    Ok used the solution of the diningexpress: "Solved, just changed db_version in the wp_options table to "22442" - and I can access it again!"

    All works now. :D


  3. freewaystudio
    Posted 2 years ago #

    Hi Johanna2patricia

    I have had the same error come up as you, but I am not that good with understanding the coding. Is there any chance you could describe your solution in more details?



  4. johanna2patricia
    Posted 2 years ago #

    Hi Joseph,
    Yes sometimes that is difficult.
    I hope you already made a backup of your database and files.
    Ok here is what you do:
    1. Login to the controlpanel of your website. The one you got from your host. Mostly it is http://www.yourwebsite.com: 2222
    2. Then login to your phpmyadmin. If you got the Directadmin controlpanel it is under the advanced options.
    3. Then in the left panel click on the database of your website.
    All the files of your website appear then at the right.
    4. Then under structure you see wp options. Click on that.
    5. Then scroll down un til you see dbversion.
    If it isn't there, scroll down to the bottom and click on the arrow for the next page. It probably is there. Else the next page until you find it.
    6. The dbversion probably says: 22441
    7. Click on that number and change it to: 22442
    8. Then click outside the table and the change has been made.
    9. Then close the controlpanel and log out.
    That should do it. Good luck!


  5. freewaystudio
    Posted 2 years ago #

    Hi Johanna

    Thanks for your quick reply, I'll see how I go.


Topic Closed

This topic has been closed to new replies.

About this Topic