Support » Networking WordPress » Database Tables Missing in Multi-site

  • Hey All!

    We have a multi-site network with over 2000 sites on it. We originally built it using wordpress MU, and have tried to keep it up to date with the merge. We were doing some testing on our development server to upgrade to 3.3 and it failed during the network upgrade when it got to a certain blog on the site. It said.

    “Warning! Problem updating . Your server may not be able to connect to sites running on it. Error message: A valid URL was not provided.”

    Well, I found the site that kept failing (remembering it goes backward through the list). When I went to the site it showed as “Error Establishing Database Connection”. This is the only site on the whole network (that I know of) that was doing this. All other sites are working fine.

    I tried logging into the dashboard and it brought up the “Repair Database” dialog. I ran the repair and it could not fix the errors, and brought up these messages.

    wp_1653_posts: Table ‘databasename.wp_1653_posts’ doesn’t exist
    wp_1653_comments: Table ‘databasename.wp_1653_comments’ doesn’t exist
    wp_1653_links: Table ‘databasename.wp_1653_links’ doesn’t exist
    wp_1653_options: Table ‘databasename.wp_1653_options’ doesn’t exist
    wp_1653_postmeta: Table ‘databasename.wp_1653_postmeta’ doesn’t exist
    wp_1653_terms: Table ‘databasename.wp_1653_terms’ doesn’t exist
    wp_1653_term_taxonomy: Table ‘databasename.wp_1653_term_taxonomy’ doesn’t exist
    wp_1653_term_relationships: Table ‘databasename.wp_1653_term_relationships’ doesn’t exist
    wp_1653_commentmeta: Table ‘databasename.wp_1653_commentmeta’ doesn’t exist

    Obviously this was the 1653rd website created on the network. Sure enough, when I went and looked at the tables in the database, none of those tables exist anymore. Not sure what happened.

    Question 1: Any idea what happened there? It is possible this happened in an older upgrade and I just missed it. The site owner never really used the site so I don’t think it is plugin related, but who knows. Any idea how to fix this error? Should I just recreate blank tables?

    The site owner does not need the site any more so we thought we would just delete the site so the upgrade could complete on the rest of the network. We went into the network admin and deleted the site, but the upgrade network keeps failing on that site. We tried looking for any references to 1653 in the database anywhere, but found nothing.

    Question 2: Assuming this is an isolated thing, anyone know how we can get past this failure in the upgrade network dialog?

    Thanks for any help you can offer!

    University of North Carolina at Chapel Hill

Viewing 10 replies - 1 through 10 (of 10 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Assuming this is an isolated thing, anyone know how we can get past this failure in the upgrade network dialog?

    yeah I’d say it’s isolated and yes you can work around it.

    On the update network page, look at the URL at the top of the screen. it has a number. change it so it skips that blog id.

    also this update process is the same one run when users login to the admin area of their sites, so not running it on some sites is not terrible. you can just visit the admin of those sites.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Question 2: Assuming this is an isolated thing, anyone know how we can get past this failure in the upgrade network dialog?

    Grab the URL from your browser when it fails. It should have 1653 in there. Update it by one to 1654, and that should get you through.

    As for where the tables went… That’s a DB issue. I would take a GOOD backup of the site and add in empty ones (or copy from a new site) just to see if that fixes it. But deleting it should have done it…

    Awesome! Thank you both for your replies. I hadn’t thought of just changing the URL. Of course that would work! 🙂

    I don’t want it to fail on future updates either though, so perhaps I will add in the tables and see what happens. Rebuilding our test server now. Thanks!

    Just wanted to post an update in case anyone has any other ideas.

    So just moving beyond the one site in the URL works great for updating the rest of the network. There was no other sites with this problem.

    In doing some more searching I found that the Settings page in network admin for this site was completely gone.


    We tried adding in the tables manually. And then trying to delete the site so it wouldn’t show up in the upgrade any more, but no luck there either. Still error’ing out.

    I am thinking at this point that this is probably a site that was not fully created, or perhaps they tried to delete it and it did not delete all the way.

    We went into the wp_blogs table in hopes of removing it there so it didn’t look for it in an upgrade, but no luck there either. It appears that when we deleted it it was deleted from this table, but continues to show up in the upgrade process.

    We’re probably going to try importing some default content in the tables for now (or find the info from a backup) to see if it will at least try to upgrade the tables so that it won’t be a problem for future updates, but I’d rather just stop it from looking for that site to update. Any ideas what the script is looking through to run the upgrades?

    Thanks so much for your help!

    The upgrade process should be pulling data from the wp_blogs table. You could also look at wp_blog_versions to make sure there isn’t a stray entry for that site in there that’s fouling up the process.

    Yeah, can’t find it there either. Going to rebuild again from production to make sure we have not messed something else up in all our testing.

    Any other possibilities? We are going to try to add the tables back in manually and then do the upgrade without trying to delete it this time.

    But I’m learning a ton about the inner workings of WordPress so at the end of the day that will be a very good thing. 🙂

    So we found a solution. Not ideal, but it works.

    We exported the tables for another site on the network and changed the URL in the table and re-imported them for the site missing tables. We’ll go back to backups if needed to get the right tables, but it worked. We can now move past these two sites, and delete them the way we want.

    That being said, we still have no idea why this happened. The only thing we can think is that on one of the restarts of the server it caused some database corruption. That is not good on a multisite network with thousands of sites.

    We found out after this that a second site (right after it in number – 1652) was also corrupted. But no others after that that we have found.

    Is there a preferred way to restart servers to minimize the risk of data corruption?

    One last update. In talking with the second site owner it sounds like their sites somehow died in the middle of creating their sites. They could never access them. It is almost like they didn’t finish creating the sites.

    Not sure why we didn’t see this error in earlier upgrades, but either way, they are fixed now and we can continue on our happy way. Thanks for all your help everyone.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Is there a preferred way to restart servers to minimize the risk of data corruption?

    The graceful linix shut down, and make good backups too. But that’s standard server stuff…

    Great. Thanks Ipstenu! I appreciate your help today.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Database Tables Missing in Multi-site’ is closed to new replies.