Support » Plugin: Keep in Touch » Database table isnt being created

  • Resolved webfeat

    (@webfeat)


    I have installed, uninstalled, and re-installed this plugin a number of times but I keep getting the following error, its a snippet :
    WordPress database error Table ‘[database-name].wp_keep_in_touch’ doesn’t exist for query SELECT * FROM wp_keep_in_touch WHERE status != ‘pending_activation’ AND weekly = 1 made by do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, Keep_In_Touch_Schedule::handle_weekly_event, Keep_In_Touch_Msg::send_weekly_digest

    on looking in the database directly I can see the table isnt there. If I send out test newsletters/digests they work fine but if I try to signup I get an error (likely due to the table not being there).
    Is this a known problem? if not, can you provide code to create the table via sql instead?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Update
    I have created the table using the create code found in – class-keep-in-touch-db
    its now in the database but the signups still fail.

    Error email reads :
    Subscription request failed for email address: [users email address]
    The cause of this error is not clear.
    It may indicate a problem with your site or on the part of the user.
    It may also indicate an attack.

    • This reply was modified 2 years, 9 months ago by webfeat.

    Have now got signups to work by enabling “Request full name”. Without this on, all signups fail.

    Also Im using the widget. When you fill in the email address, and click signup, it then goes to a page asking you to put your email address in to sign up. Can this be an option we can turned on/off? asking someone to put their address in twice is tedious. Our site is protected but a sitewide login so no bots can access it.

    Obviously now I have to have Request full name on, they will need to put in their name but if this could be added to the widget, and perhaps ajax update the widget to confirm signup? or just go to a confirmation page if not?

    • This reply was modified 2 years, 9 months ago by webfeat.
    • This reply was modified 2 years, 9 months ago by webfeat.
    Plugin Author racanu

    (@racanu)

    Hi,

    Thanks very much for taking the time to work through the problems and report the issues you’ve found.

    The widget was pretty much only used by me until now and I’ve been a bit careless with the changes 🙂 The problems you report all seem to have to do with my latest changes, where I introduced the name field.

    I understand you’ve got the plugin working for you albeit with some limitations. Can you give me a feel of the urgency of these problems for you? Can it wait like until the weekend or so?

    Hi
    Theres no rush as its not open to the public yet so the weekend would be fine with me.

    thanks for looking into it

    ps
    for the input field can you add a class name for it, or an input type? Im trying to put css on it but if I just use input it styles the button as well.

    I have used : input:not([disabled]):not([type=”submit”]) for now but its not ideal.

    Would like the inline style taken off the input box as well please. I use a css plugin to add additional styles and so can add it in there.

    • This reply was modified 2 years, 9 months ago by webfeat.
    • This reply was modified 2 years, 9 months ago by webfeat.

    sorry for the spam. Is there a file I can edit to change the style of the email sent out? want to do some formatting.

    Plugin Author racanu

    (@racanu)

    Unfortunately no, there is no file to style the emails. They are hardcoded together with any style they may use.

    I am not not weathered in html/css proper usage so if you have good ideas on how to achieve that I’d like to hear them. I guess you may even submit changes.

    I was planning to make the messages configurable, but wasn’t planning to do extensive styling also because my few attempts to get styling of html emails right have failed miserably. So I settled to something that is just about acceptable.

    You seem to have quite some insight into this so I am all ears. 🙂

    ok thanks, I see the styling is inside class-keep-in-touch-msg.php so I’ll play with those. Email styling can be a problem as a lot of older readers ignore newer stuff.

    I have noticed that the scheduled task isnt sending anything out. I’ve looked at the cron job and it set as non-repeating for both “keep_in_touch_daily_event_hook” and “keep_in_touch_weekly_event_hook”, is that right? If I manually send out the newsletter via the WP admin area its sent but its not sending on schedule.

    hi again
    do you have a person email I can use instead of this? as Im not sure its all relevant for a support ticket?

    I have some ideas regarding the styling. I can/am edit the msg file but those styles will get replaced on update. So better perhaps to put them in the database, then copy them into the email when its created.

    Plugin Author racanu

    (@racanu)

    It’s true, both schedules are non repeating because when they’re triggered I reschedule them. On my site they both work well although I have the (unconfirmed) feeling they don’t trigger at the assigned time but sometimes much later. My theory was that it was a problem of my hosting installation but haven’t looked into it. There’s also the issue of the time zone which I’ve also not fully cleared up, maybe that’s what you’re encountering.

    My personal email is: racanu@gmail.com

    I’m not sure I understood the last statement about the styles.

    Thanks, I’ve fired an email your way about the styles with some example files.

    The schedules need to be repeating. I’ll edit mine. Currently its never sent anything out despite my changing the times/days repeatedly to test it i.e. 3 times today I’ve set it to send 30 minutes from whatever time I was looking at it. So far, nothing.

    I can manually send them out, via keep in touch options. If I try running from the Cron tab nothing comes out but the timers change like its been sent but nothing arrives.
    Its not a deal breaker but would be nice to get working.

    • This reply was modified 2 years, 9 months ago by webfeat.
    Plugin Author racanu

    (@racanu)

    Umm, the schedules do repeat if they’re fired, only not automatically. The event handler (that also sends the email) recreates a new scheduled event each time. I think I did this because somehow I had troubles with the recurring schedule. But I can have a look at it again to see if it’s possible to set it recurring.

    There’s a plugin called Cron GUI that shows you what’s in the scheduler’s queue. You may want to have a look to see at least if the scheduled events are being removed which is an indication of whether they’re being triggered or not.

    It would very weird if they’re not being triggered. You say that sending mails on request does work so that eliminates the possibility that there’s anything wrong with sending the email.

    Thats true
    I set it for 4pm, UK time, at 3.50. from looking at the cron the event triggered as its now reset to :
    keep_in_touch_daily_event_hook None Keep_In_Touch_Schedule::handle_daily_event() 2017-06-15 16:00:00 (23 hours 58 minutes) Non-repeating

    so its firing, but nothing is being mailed out. Most strange.

    Plugin Author racanu

    (@racanu)

    The database issues should be fixed in 1.2

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Database table isnt being created’ is closed to new replies.