[resolved] Database restoration between versions? (6 posts)

  1. dss
    Posted 9 years ago #

    I have a .sql backup for my little sister's blog (WordPress 2.0) and would really like to restore (at least) the posts to her new location.

    Sadly the new location is WP 2.0.4

    When trying to insert the contents of the .sql I get syntax errors, and trouble.

    Is there something I don't see immediately, or understand (likely) abour how to restore between versions? Is this even possible?

  2. Kafkaesqui

    Posted 9 years ago #

    Have you tried running wp-admin/upgrade.php?

  3. dss
    Posted 9 years ago #

    Yes, I did. I kinda thought that was the problem. The backup database is from 2.0 and the install at the new location is 2.0.4.

    The new location's database won't accept the old data without reporting either "syntax" errors or "sql" errors.

    I'm considering repointing the domain back to the old site and attemting to import via rss if all else fails, but the tables at least appear to be the same, and in the same order. I don't really see what's wrong.

    * shrug *

  4. Joshua Sigar
    Posted 9 years ago #

    If the new wp is brand new a.k.a an empty blog, then start off with version 2.0, restore the backup, then upgrade.

    If you can't start off with version 2.0 on the new location, then restore the backup on wp 2.0 somewhere else (there's always local server option), upgrade, back up, and restore on new location.

  5. dss
    Posted 9 years ago #

    I'll try upgrading the old site.

    * fingers crossed *

  6. dss
    Posted 9 years ago #

    It worked.

    Here's what I did:

    In phpmyadmin:
    I dropped the tables created previously.

    replaced the schema from the backup.

    then added the content one section at a time by opening the document, selecting the content (avoiding all commands apart from insert into and what follows. clicked on sql in the topmost menu of phpmyadmin, and pasted the clipboard into the input field. clicked go.

    For whatever reason this avoided sql error and permission issues and worked.

    Once all the data was back in, I repaired the database, and then ran the upgrade.php

    All is well.


Topic Closed

This topic has been closed to new replies.

About this Topic