Support » Plugin: WP-Lister Lite for eBay » Database not created

  • Resolved tex0gen

    (@tex0gen)


    The following error is generated when visiting the settings of the plugin.

    WordPress database error: [All parts of a PRIMARY KEY must be NOT NULL; if you need NULL in a key, use UNIQUE instead]
    CREATE TABLE IF NOT EXISTS <code>wp_ebay_sites</code> ( <code>id</code> int(11) DEFAULT NULL, <code>title</code> varchar(128) NOT NULL, <code>code</code> varchar(16) DEFAULT NULL, <code>url</code> varchar(64) DEFAULT NULL, <code>enabled</code> int(11) DEFAULT NULL, <code>sort_order</code> int(11) DEFAULT NULL, <code>last_refresh</code> datetime DEFAULT NULL, <code>categories_map_ebay</code> text NOT NULL, <code>DispatchTimeMaxDetails</code> text NOT NULL, <code>MinListingStartPrices</code> text NOT NULL, <code>ReturnsWithinOptions</code> text NOT NULL, <code>CountryDetails</code> text NOT NULL,	<code>ShippingPackageDetails</code> text NOT NULL, <code>ShippingCostPaidByOptions</code> text NOT NULL, <code>ShippingLocationDetails</code> text NOT NULL, <code>ExcludeShippingLocationDetails</code> text NOT NULL, PRIMARY KEY (<code>id</code>) ) DEFAULT CHARSET=utf8 ;
    
    WordPress database error: [Table 'wpro.wp_ebay_sites' doesn't exist]
    SHOW FULL COLUMNS FROM <code>wp_ebay_sites</code>

    Running PHP7 on Apache with Ubuntu 16.

Viewing 7 replies - 1 through 7 (of 7 total)
  • tex0gen

    (@tex0gen)

    Do you guys even test with debug mode ON? I’m sat looking at a flood load of PHP Notices.

    Notice: Undefined offset: 0 in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/page/ProfilesPage.php on line 119
    
    Notice: Trying to get property of non-object in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/page/ProfilesPage.php on line 119
    
    Notice: Undefined property: WPLE_eBaySite::$ShippingLocationDetails in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayShippingModel.php on line 427
    
    Notice: Undefined property: WPLE_eBaySite::$ExcludeShippingLocationDetails in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayShippingModel.php on line 436
    
    Notice: Undefined property: WPLE_eBaySite::$CountryDetails in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayShippingModel.php on line 449
    
    Notice: Undefined property: WPLE_eBaySite::$DispatchTimeMaxDetails in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/eBaySite.php on line 114
    
    Notice: Undefined property: WPLE_eBaySite::$ShippingPackageDetails in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/eBaySite.php on line 117
    
    Notice: Undefined property: WPLE_eBaySite::$ReturnsWithinOptions in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/eBaySite.php on line 120
    
    Notice: Undefined property: WPLE_eBaySite::$ShippingCostPaidByOptions in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/eBaySite.php on line 123
    
    Notice: Undefined offset: 0 in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayCategoriesModel.php on line 385
    
    Notice: Trying to get property of non-object in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayCategoriesModel.php on line 386
    
    Notice: Undefined offset: 0 in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayCategoriesModel.php on line 420
    
    Notice: Trying to get property of non-object in /home/wpro/public_html/wp-content/plugins/wp-lister-for-ebay/classes/model/EbayCategoriesModel.php on line 421
    WP Lab Support

    (@wp-lab-support)

    Hello tex0gen.

    I am sorry to hear about the issues you are having, but I am happy to help. Unfortunately this is something a developer will need to examine, so I have notified them of this and as soon as I have something for you I will get back to you in this forum thread.

    Kind regards,
    John

    Hello tex0gen.

    I can send you the SQL file for the ebay_sites table that appears to be missing in your install. All the other notices seem to be related to the missing table so most if not all of them should clear up as soon as that missing ebay_sites table is created.

    I would not suggest you provide your email in this forum thread (for me to send you the file), so instead why don’t you open a ticket here: Support Form and ask for the “ebay_sites” table that is missing and I will send you the sql file through email.

    Kind regards,
    John

    Amazing, thank you very much.

    Any idea why this happened? I did try re-installing with the proper selected option to remove the installation but no luck.

    Thank’s again, will be in touch shortly.

    Hello tex0gen

    It seems to happen with some databases that have a different prefix on their database tables if I remember correctly. We can discuss in further detail with the developer through your ticket if you would like.

    Kind regards,
    John

    Plugin Author WP Lab

    (@wp-lab)

    This issue where the ebay_sites table wasn’t created during the initial setup process should be finally fixed in the latest version 2.0.17. It only happened on very few servers with a particular MySQL configuration, which is why we couldn’t identify the actual reason for this problem until a few weeks ago.

    kind regards,
    Matt

    No worries. Thank you for the update!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Database not created’ is closed to new replies.