WordPress.org

Support

Support » Installation » database name problem

database name problem

  • Is there some sort of limitation to the length a database name can be in wordpress? My host prepends this information to the database name:
    friendshipcorner_net_-_
    Then I create the database ‘wpress’ and insert ‘friendshipcorner_net_-_wpress’ into my wp-config.php file. Username and password have been triple checked, but I’m still greeted with the wonderful error “Error establishing a database connection!”
    Feel free to see for yourself here.
    Any help would be appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • wantmoore,
    How about posting the actual code from wp-config.php? Sometimes you look at the stuff over and over again and you just don’t see a problem. Perhaps some fresh eyes could be of some assistance.
    Craig.

    Sure thing,
    This is my latest attempt from the nightly from the 24th. Same problem with prior nightlies and the 1.0 release.
    <?php
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘friendshipcorner_net_-_wpress’); // The name of the database
    define(‘DB_USER’, ‘friendship’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define(‘ABSPATH’, dirname(__FILE__).’/’);
    // Get everything else
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    Is your user “friendship” a member of the database? Check to see that it is indeed a member. I can’t see any problems with the code above. So it seems likely that the user doesn’t have access privileges to the database.

    Yeah, it certainly does. It’s the admin account for the entire domain and is the same one used to login to PHPMyAdmin. That’s why it doesn’t make any sense.

    Hrmm… did you install phpmyadmin yourself, or is it set up by your provider? I know with one provider I had, when they appended stuff to the database name they also appended it to the username… so you could try appending friendshipcorner_net_-_ to your username as well. Something to consider.

    It is all setup my my host. They use the ensim control panel. My other hosts use cPanel which does append the domain, or a shortened version of it to the database name and user name. Not the case here though, as ‘friendship’ and the admin password are exactly what I use to login to PHPMyAdmin. Anyone else have any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘database name problem’ is closed to new replies.
Skip to toolbar