WordPress.org

Forums

Database Name Length (4 posts)

  1. pagangeek
    Member
    Posted 11 years ago #

    Is there a limit to how long the DB name can be? I seem to be having issues with a rather lengthy name (basically WordPress is reporting what I've included below), and I can't see any other issue.
    I should mention that I've previously gotten WordPress to work on this very same server/configuration using a short DB name, but had to abandon that installation for various reasons. I just thought I would consult with those who may know best, and see if perhaps the name length was the issue.

    We're having a little trouble selecting the proper database for WordPress.

    • Are you sure it exists?
    • Your database name is currently specified as pagangeek_grey_council_org_wordpress. Is this correct?
    • On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    Thanks for any help you can provide...
    PG

  2. pagangeek
    Member
    Posted 11 years ago #

    I thought about that, but PHPmyAdmin shows the name as long as I presented it here.
    And of course, I find out that I'm downloading and using WordPress 1.0.2 - I signed up for the mailing list, but I never got an announcement about the latest version.
    When I get home (and have shell access) I'll upload the latest copy and see if that works - otherwise back to my host I suppose I'll have to go, bah...

  3. pagangeek
    Member
    Posted 11 years ago #

    Does anyone know if WP 1.2 might correct this issue?
    It's not like I have a choice about the prefix on my DB's - it's the way the server farm has the servers configured, and unfortunately my host can't override the settings. Yeah, it sucks, but you can't beat my host - I love 'em.
    Thanks...

  4. pagangeek
    Member
    Posted 11 years ago #

    Ok, figured it out.
    Stupid DB management software (combination of "DB Manager" and "PHPmyAdmin" didn't add the default user as an ODBC connect with localhost.
    Evidently, it's broken (won't automatically add "localhost"), and you can't add it manually. Time for another support ticket.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.