Support » Plugin: WP Migrate DB » Database Moves – Pages, Post, Settings DO NOT SHOW

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Brad Touesnard


    Hi, I’m not sure what the problem would be here. No one else has reported any issue like this, which leads me to believe there is something “special” about your data or database. Maybe you could upload your database to Dropbox/Google Drive and send me a link to download it? Then I can debug the issue.

    I was just running into a similar issue. I used your tool to create the backup, then used One-Click Install on Dreamhost to create a new instance of WordPress, then used phpmyadmin to import the backup.

    Upon import it looks like a new set of tables was created with new prefixes; i.e. “wp_h76j6o_posts” was created by the import and “wp_agfy7i_posts” was created by the one-click-install

    I take full responsibility for doing something wrong – I just don’t have a clue what 🙂

    sorry, posting again so I can subscribe to responses – forgot to do that last time

    @jayleask: in your case I think the problem is related to the custom table prefixes that Dreamhost uses in their one-click wordpress installs. This results in two wordpress sites using differnt table prefixes (in your case wp_h76j6o_ and wp_agfy7i_). You can fix this very easy. After importing the database, open the wp-config.php file and look for the following (probably in line 62):
    $table_prefix = 'wp_agfy7i_';
    Change it so it uses the prefix of the imported database:
    $table_prefix = 'wp_h76j6o_';
    After saving it should now show all the posts. You can delete the tables created by the one-click install (although leaving them there won’t hurt anybody).

    And btw, you can subscribe to a thread by clicking ‘Subscribe to topic’ in the right sidebar.

    Thank you,

    Though I did not use your tool, I had exactly this problem. Changing the prefix from within PHPmyAdmin worked perfectly!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Database Moves – Pages, Post, Settings DO NOT SHOW’ is closed to new replies.