Support » Plugin: Centrora WordPress Security™ » Database install doesn't work

  • Resolved GermanKiwi


    Hi, I have two separate WP sites, and both have been running OSE Firewall 1.6.4. Yesterday I upgraded OSE on both sites to 2.1.2.

    Afterwards, on the first site, I clicked the “Install” button to create the database table, and this worked fine – the big red box appeared and showed the steps it was taking to create the tables, and there were no errors.

    But on the second site, when I clicked the “Install” button, it brings up the big red box and shows “Database installer preparing in progress”, but nothing more happens. It just sits there with that text inside the red box, forever until I close the box. I’ve tried this in IE and Firefox, multiple times, but no joy.

    I’ve also tried completely deactivating and uninstalling the plugin, and then reinstalling it, but it still does this.

    I’m not using version 2.1.3 since today, but it still won’t work – same issue.

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author ProChase


    Hi Kiwi,

    After our IT department check, your issue might be the PDO is not installed in that server, could you please check this page to get more information:

    Let me know if it not works or you have any further questions, your feeling is important for us. Thanks very much!

    Best wishes
    Security Consultant @ ProWeb Team

    Thanks Chase. However I don’t believe that PDO is the cause of this. First of all, I have not received any PDO error such as “Class ‘PDO’ not found”. The only thing that I get, when I click the Install button, is the big red box with “Database installer preparing in progress”, but nothing else. No errors about PDO or any other errors.

    (I can send you a screenshot if you need).

    In addition, both of my WordPress websites are running of the same web server, using the same installation of Apache and PHP. As I explained, the first website worked fine when I clicked the Install button. But the second website did not. If PDO was missing from the server, then both websites should have given me an error about PDO, right?

    In any case, the server is running PHP 5.54 and nothing has been disabled.

    Let me know what else I can try!

    Plugin Author Helix.L


    Hi there

    Yes, a screenshot can help us a lot in identifying the, could you please follow this tutorial and use Firebug to send us a screenshot here and CC a copy to We will be able to sort out the issue once we see the error,

    Best wishes

    Plugin Author Helix.L


    Hi again

    Sorry that i forgot to post the link, here it is:

    Best wishes

    Plugin Author Helix.L


    Thank you for your cooperation in advance! 🙂

    Good morning,
    I have the same issue.
    5 website on the same provider, same configuration, but one of these has got the same symptoms here listed.
    The database installer seems to start and after these messages:
    > Create Base Table Completed, continue…
    > Inserting Configuration Data Completed, continue…
    > Inserting Email Content Completed, continue…
    > Attack Type Information Installation Completed, continue…
    > Basic Ruleset Installation Completed, continue…
    What can I do ???
    Please help me..
    Thank You very much
    P.s. It would be wonderful share informations with other users…

    Plugin Author Helix.L



    Please try to go to Configuration –> Uninstall to uninstall the database first, then try to install the database again and see if it works? If not, please send a temporary wordpress admin account to me at:

    I will check it asap.

    Best wishes

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Database install doesn't work’ is closed to new replies.