Support » Fixing WordPress » Database / Header / Error / Help Please!

  • creativeclicks

    (@creativeclicks)


    Sorry this a re-post as I had no replies before. I’m hopig someone can help this time!

    Hi,

    I have been running a fairly recent version of wordpress for several months now without a glitch. Fantastic software! However I recently started getting the following error when trying to add / modify a post.

    I have checked the WordPress FAQ’s and the support forums for this problem and have tried everything that’s been suggested i.e. removing any whitespace (using Dreamweaver). I’m not able to find a specific support post for the page/s that seem to cause the problem. Any help would be much appreciated. Thanks in advance.

    — error message —
    Warning: Cannot modify header information – headers already sent by (output started at /data/11/0/112/128/764617/user/782111/htdocs/site/en/wp-includes/wp-db.php:102) in /data/11/0/112/128/764617/user/782111/htdocs/site/en/wp-admin/post.php on line 122
    — error message —

Viewing 6 replies - 1 through 6 (of 6 total)
  • plutone

    (@plutone)

    I got a similar problem logging in!

    I just tried to install WordPress for the first time. My MySQL is not on localhost where the website runs, I hope this might explain something to the experts.

    I get the same errormessage, several times. My first impression would be that it has to do with file protection.

    Does anyone have an idea where to look?

    plutone

    (@plutone)

    In My case, the problem was caused by trailing space in the WP-config file. Make sure that it looks like:

    ————-file wp-admin.php: first line just <?php

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘mydb’); // The name of the database
    define(‘DB_USER’, ‘dbuser’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘dbpwd’); // …and password
    define(‘DB_HOST’, ‘myhost’); // 99% chance you won’t need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ‘nl_NL’);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    ——————so not even a white space as trailing char.

    Thanks I’ll check that out and let you know how I get on!

    Still no joy. Error message as follows:

    –error message–

    Warning: Cannot modify header information – headers already sent by (output started at /data/11/0/112/128/764617/user/782111/htdocs/site/en/wp-includes/wp-db.php:102) in /data/11/0/112/128/764617/user/782111/htdocs/site/en/wp-admin/post.php on line 122

    –error message–

    Checked files; wp-db.php and post.php and wp-config.php for trailing white space but it all looks clear to me?

    Any other ideas!?

    Thanks

    strange – above just seems to happen with one particular post?

    I’m really sorry, I am just a novice user with no knowledge of PHP at all.
    Just downloaded wordpress 2.0.3, and it worked after the white space correction.
    Maybe it could help to choose an other template?
    I was quite happy with the greentrack template, modified it a little bit (translated it in dutch).
    You can get an impression of what is possible with WordPress for a complete novice user at http://plutone.labarca.nl

    grtz,
    Plutone

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Database / Header / Error / Help Please!’ is closed to new replies.