Support » Plugin: The WP Remote WordPress Plugin » Database export/import problem

  • Hi!

    I have a very strange problem when trying to import back database files created by WP Remote (manual) backup.

    When importing database file in phpmyadmin I get #1064 error and upon investigating I found out that the backup file created by WP Remote is missing all of the quotes surrounding the dates in WPML tables in my database. When those quotes are added, importing the database works fine.

    Also, when I manually backup the database, all those dates are surrounded with quotes which means that manually backuped up file via phpmyadmin works just fine.

    What is the problem and is there something I can do about it? Because if this pertains (for me) I’m afraid, database backuping via WP Remote is unusable for me.

    Thank you for all your work!

    http://wordpress.org/plugins/wpremote/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor cuvelier

    (@cuvelier)

    Hey there!

    Thanks for reaching out!

    This sounds like a great bug you’ve discovered! If you’d like to help us solve it, it would be great if you could email us at support@wpremote.com and we can take a closer look at everything!

    Cheers!
    Owain

    Hi!

    I just sent an email with details, screenshot and a database file to your support.

    Thanks for a quick reply and help!

    Cheers! 🙂
    Dario

    Hi Dario,
    I’m having the same problem… but I’m not much of a database person…

    Can you provide the gory details of what you did to fix the database?

    I have a WPRemote .tar.gz backup and when I try to import it I get a #1064 error

    Thanks!

    Hi!

    When I tried to import the database in phpmyadmin I got an error which pointed to WPML table “wp_icl_string_translations”, saying:
    “#1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ’09:54:02)’ at line 5.

    So, I opened up the SQL file in the editor and found the line which “broke” the SQL import (that’s the line that the error tells you about) and just added quotes around the timestamps.

    For example 2012-06-2909:54:02 must be surrounded with qoutes.

    As you look at the data that is in the same part of your SQL file, you will notice that all the timestamps from that WPML table are missing the quotes. So now you have to manually add the quotes to all the timestamps that are missing them.

    Don’t worry, if you happen to forget some timestamp it will just give you the same error during import and it will point you to the line in question.

    I was lucky that the database in question was for relatively small website so the manual fix took about half an hour.

    Owain from WP Remote said that they are working on the fix and that it should be included in the next version of the plugin. Since I really like the plugin and service I will manually backup my databases until then.

    Plugin Contributor Daniel Bachhuber

    (@danielbachhuber)

    We’ll try to get the new version of the plugin out this week. Thanks for your patience!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Database export/import problem’ is closed to new replies.