Support » Plugin: Pods - Custom Content Types and Fields » Database error when trying to delete CPT and taxonomies in a WordPress multisite

  • Resolved Xaifu

    (@xaifu)


    Hello

    I created a multi-site in WordPress and used the Multilingualpress plugin to generate a copy of my site to use as a second language.

    In the main site of the multi-site I have a CPT and a custom taxonomy made with pods.

    I know that Multilingualpress doesn’t support pod CPT. CPTs and taxonomies are copied to the second site but they don’t work.

    I can create new CPTs and taxonomies on the second site and they work fine.

    From the pod administration of my second website I have tried to delete the CPTs and taxonomies that have been copied from the main site, but an error of this type always occurs:

    Database Error; SQL: DELETE FROM'ac_2_podsrel'WHERE ('pod_id'= 0 AND'item_id'= 883 ) OR ('related_pod_id'= 0 AND'related_item_id'= 883 ); Response: Table 'midatabase.ac_2_podsrel' doesn't exist

    I also tried to restart and clean the pod data from the settings but a similar error occurred.

    My question is, is there any way to delete the CPT and taxonomy that have been copied to the second site?

    Thanks!
    Daniel

    • This topic was modified 4 months, 2 weeks ago by Xaifu.
    • This topic was modified 4 months, 2 weeks ago by Xaifu.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jory Hogeveen

    (@keraweb)

    It seems that while copying the site it didn’t copy all tables correctly.
    You could try to re-activate Pods on this installation only. After that the table should be created. This will prevent the above error from happening.

    Cheers! Jory

    Thanks for your reply Jory

    I’ve re-activated pods in the second installation but the problem continues.

    The problem seems to be that when I try to delete the CPT or custom taxonomy it searches for the database ac_2_podsrel and it doesn’t exist. I can only see the table ac_podsrel in PhpMyAdmin which I suppose is from the primary site in the multisite.

    Any suggestion on how to proceed?

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @xaifu

    Not sure honestly. Re-installation should normally work. Do you see any errors while activating Pods?
    You could also manually copy the podsrel table and rename that to ac_2_podsrel. It isn’t a fix to the issue but you’ll have to ask the developer from the blog duplication plugin for that.

    Cheers, Jory

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.