Database Error when Publishing/Editing (5 posts)

  1. drienne
    Posted 10 years ago #

    I am running WordPress 2.0.2. I get this error when I am using Windows OR Mac, and Firefox, Safari, or Internet Explorer.

    Here it is. Whenever I publish a new post or edit an existing post, I get the following error. (After clicking "Publish" (or "Save"), the wp-admin page sits there for about 2 minutes, then produces this error on post.php.)

    WordPress database error: [Lost connection to MySQL server during query]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('314','_encloseme','1')

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/d/r/i/drienne/html/wordpress/wp-includes/wp-db.php:102) in /home/content/d/r/i/drienne/html/wordpress/wp-admin/post.php on line 60


    This error does NOT occur when I delete a post or save one as a draft (unpublished), and does not occur when a comment is left either.

    Line 60 of post.php says... "header("Location: $location");"

    I have emptied my cookies and cache, lowered my security settings, tried it with and without firewall, with and without antivirus.

    Someone suggested to me that I have a corrupted database, so I backed up my tables, deleted my database and started a new database. I loaded the tables in to the new database, and the error still persists.

    I am running one plug-in, called "Did You Pass Math?" which is on the wp2 compatibility list I believe. I have tried turning it off and that doesn't make the problem go away either.

    I emailed my hosting service (godaddy.com) and asked if they could restart the server my db is on, but they said that was not an option.

    This error began out of the blue approximately 1 week ago. I did not edit, replace, or manipulate any of my files, it just randomly started. I upgraded to WordPress 2.0.2 several weeks ago, and it was running perfectly until now.

    I want to note that while I do get this error message every time I publish or save, the changes/new posts DO appear on the blog and are saved in the tables. But this error.. it's inconvenient and irritating.

    Can someone help me?

    My blog, by the way, is http://www.morechickenandtuna.net/wordpress/

  2. drienne
    Posted 10 years ago #


    Come on... anyone have ANY suggestions? Please help - I'm at the end of my rope here.

  3. Chris_K
    Posted 10 years ago #

    When you're at Admin, Options -> Writing, what do you have for "Update Services"? If pingomatic is in there, try removing it and then making a post.

  4. jaredquinn
    Posted 10 years ago #

    Do you have access to your mysql logs to find out why the database connection may have been lost?

  5. Tina2006
    Posted 10 years ago #

    I had the same problem, removing pingomatic.com worked.

Topic Closed

This topic has been closed to new replies.

About this Topic