Support » Plugin: WordPress Related Posts » Database error, table 'wp_wp_rp_tags' doesn't exist

  • Resolved prezla


    WordPress database error Table ‘wp_database.wp_wp_rp_tags’ doesn’t exist за упит SELECT label FROM wp_wp_rp_tags WHERE post_id=98734; направљен од require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), include(‘/themes/srbin/single.php’), get_template_part, locate_template, load_template, require(‘/themes/srbin/content-single.php’), wp_related_posts, wp_get_related_posts, wp_rp_get_related_posts, wp_rp_fetch_posts_and_title, wp_rp_append_posts, call_user_func, wp_rp_fetch_related_posts_v2

    There is too much error_log file.
    How to reinstall and create the necessary fields in the database.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hey Prezla, sorry for not getting back to you anytime sooner, but I just wanted to say that we’re looking into the reported error and that we’ll get back to you as soon as we know more (hopefully soon)!

    Big thanks for bringing this forward to us and please do not hesitate to let us know if something similar happens again. And we’ll keep you posted about what’s going on on our side as well!

    Thanks, take care & have a nice day!



    Do you have a full access to your blog’s database? We think we might be able to help you out, if yes.

    Let us know! Also — here’s my email address:

    Looking forward to your reply!


    Due to the Easter holidays just now am able to contact you.
    Yes, I have full access to the database.
    How can I solve the problem? Do I need to manually create the table?


    Hey Predrag, no worries, hope you had fun with your family celebrations! 🙂

    Yeah, try to manually create the table by running the code below:

    CREATE TABLE wp_wp_rp_tags (
     post_id mediumint(9),
     post_date datetime NOT NULL,
     label VARCHAR(32) NOT NULL,
     weight float,
     INDEX post_id (post_id),
     INDEX label (label)

    Let me know if this helped in any way or not. We’ll see what to do from here on.

    Srdačan pozdrav iz Ljubljane! 🙂


    WordPress database error Illegal mix of collations for operation ' IN ' за упит
    			target.post_id, sum(target.weight * log(1 / least(1, freqs.freq))) as score
    			wp_wp_rp_tags as target,
    			(SELECT label, count(1) as freq FROM wp_wp_rp_tags
    				WHERE label IN ('P_договор', 'P_модел', 'P_Република Српска', 'P_Србија', 'P_терориста', 'P_Хашим Тачи', 'C_Актуелно', 'C_ПОЛИТИКА', 'A_app', 'A_2')
    				GROUP BY label
    			) as freqs
    			target.post_id NOT IN ('90134') AND
    			target.label=freqs.label AND
    			target.label IN ('P_договор', 'P_модел', 'P_Република Српска', 'P_Србија', 'P_терориста', 'P_Хашим Тачи', 'C_Актуелно', 'C_ПОЛИТИКА', 'A_app', 'A_2') AND
    				target.post_id NOT IN (
    					SELECT post_id FROM wp_wp_rp_tags
    					WHERE label IN ('C_dokumentacija', 'C_Афоризми', 'C_ВИДЕО')
    		GROUP BY target.post_id
    		ORDER BY score desc
    		LIMIT 14; made of require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/srbin/single.php'), get_template_part, locate_template, load_template, require('/themes/srbin/content-single.php'), wp_related_posts, wp_get_related_posts, wp_rp_get_related_posts, wp_rp_fetch_posts_and_title, wp_rp_append_posts, call_user_func, wp_rp_fetch_related_posts_v2

    It’s one of the mistakes.

    The error is generated in Cyrillic. I translated for convenience if anyone else has the same problem.

    Pozdrav iz Beograda 😉

    Hey Prezla!

    After a short inspection with our sysadmin, this looks like a bit harder MySQL settings problem in our servers, that might not be resolved any time soon-ish, since we need some time to replicate it.

    For now I can only ask you to bear with us until we can give you any more insight on this. We do appreciate your feedback though, since it’s always nice to detect these kind of problems sooner than later! So — thank you! 🙂

    And please do not hesitate to let me know if you have any other questions regarding our service — I’ll be more than glad to help you out!

    Take care & prijatno!



    i also get this error :
    table ‘wp_wp_rp_tags’ doesn’t exist

    my database doesnt start with the traditional “WP_” setup.

    any update?

    Hey! Sorry, but still no major update on this. We are working on it and we certainly hope we’ll have some good news for you as soon as possible. Please bear with us!

    Thanks for all your patience on this matter! Appreciated!


    I believe that the error due to Unicode. When I look at the data in your table do not see a Cyrillic inscription.

    Unicode error


    Well, after a manual audit, we noticed that this issue is a bit more complex than we initially thought and that this is mostly due to mixed collations (mixed letters). It seems as if MySQL cannot sort those two together and that’s why all (more or less) got messed up.

    We can brief you with a more detailed answer, if you wish so, via email, but the bottom line is pretty much the same: due to different lettering combination MySQL tends to experience some problems; unfortunately also with our plugin.

    We are of course really sorry for this, but since any solution to this problem is out of our reach, we are just not able to push any fix towards this problem.

    Let me know if you have any other questions — I’ll gladly help! Here’s my email address:

    Take care & have a happy Monday!


    Thanks for the feedback, that is unfortunate.
    I see 2 options, we can try resolve this issue together or i will be forced to look for an alternate plugin which can accommodate my setup.

    is it really necessary to have the plugin implement code into the database?
    Being said, currently there is no BH_wp_rp_tags table in the database and the plugin works fine. I just keep getting errors in my newrelic system which ideally slows the site down at time due to it trying to find that table.
    Can i remove the function from the plugin? If so how?


    Hey @ binarylimited!

    Yeah, it is possible to remove this function, if you wish to do so.

    You can find it in wp_related_posts.php file, delete the lines where this is used: wp_rp_fetch_related_posts_v2

    Hope it helps! Let us know!

    Take care!


    should i remove the 2 instances :
    wp_rp_append_posts($related_posts, 'wp_rp_fetch_related_posts_v2', $limit); ?


    have removed both lines containing wp_rp_fetch_related_posts_v2′, $limit); , cleared the cache and still get the errors.

    I removed this version and installed Zemanta version.
    Now everything is OK.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Database error, table 'wp_wp_rp_tags' doesn't exist’ is closed to new replies.