Support » Plugin: Broken Link Checker » Database error : Table ‘tablename.wp_blc_links’ doesn’t exist

  • Hi, I’ve installed the plugin but it doesn’t seem to work. On the view-broken-links page, I see the error:
    Database error : Table ‘tablename.wp_blc_links’ doesn’t exist
    Please help,
    Thanks!

    • This topic was modified 1 month, 3 weeks ago by dugublack.
Viewing 11 replies - 1 through 11 (of 11 total)
  • I have the same problem. What I do is rollback “Broken Link Checker” (using WP Rollback) to 1.11.10, activate the plugin then update it to 1.11.11. Now you have the missing tables and the updated plugin.

    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi all,

    @dugublack can you tell me which version you have installed on your site and which PHP and WP do you use?

    @debra15 if I understand this correctly the issue happens only if you install 1.11.11 cleanly, if you install 1.11.10 and then update it works fine?
    Can you also tell me which WP and PHP versions do you have running on your site?

    Cheers,
    Predrag

    Yes. This is the first time I install your plugin.
    Yes. It works great now.

    WordPress 5.3.2
    nginx/1.17.5
    PHP 7.3.6-1+ubuntu16.04.1+deb.sury.org+1

    I’ve got the same error.

    I have the same error.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @debra15

    Thank you for confirmation and info about the system.

    @synthea @moofum

    Could you please try the same – roll ack to previous release: install it and then upgrade to newest one?

    If that works for you, please confirm and we’ll report the issue for further investigation by our developers.

    Kind regards,
    Adam

    Yes, that does seem to work.

    I’m having this same problem. Trying to install v1.11.11 fresh. Never installed this plugin before, so there’s nothing in-place to upgrade from. Not interested in installing another “rollback” pluging. Would rather just install this one fresh.

    Running
    Wordpress v5.2.5
    PHP version 7.2.27
    Mysql version 5.5.60-0

    Yes, it worked to install 1.11.10 and update that.

    @sector13 Thought the same as you as 1.11.11 was fresh install for me. Bit the bullet and installed rollback, went back to 1.11.10, activated, updated back to 1.11.11 then deleted rollback plugin. Now have exactly same setup as before but Broken Link Checker now running fine. Took me 2 mins start to finish.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hello!

    @moofum @synthea @ashburnham

    Thank you for giving it a try and for confirmation!

    @sector13

    Not interested in installing another “rollback” pluging. Would rather just install this one fresh.

    I understand that and I’m sorry for inconvenience. However, as for now it is the simplest and fastest workaround to make the plugin work. I absolutely agree that it’s something that needs to be fixed and it’s already reported as a bug to our developers but I’m not able to give an ETA on the fix release.

    Kind regards,
    Adam

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.