WordPress.org

Forums

Database Error - data too long for column (5 posts)

  1. dlcmpls
    Member
    Posted 6 years ago #

    When a user submits a post via email, we sometimes get this error message:

    WordPress database error Data too long for column 'post_content' at row 1 for query INSERT INTO wp_posts

    We sometimes get that error, but not all of the time.

    Does anyone have thoughts on the problem?

    dlc

  2. itangent
    Member
    Posted 6 years ago #

    Hey dlc,

    Have you checked your collation type for the columns in MySQL? We had a similar issue with a site we developed and found that if we changed them all from latin1_swedish_ci to utf8_general_ci that made the difference.

    Good luck!

    iTangent

  3. CoastalData
    Member
    Posted 5 years ago #

    Hello, I'm getting this error on a brand new install of WordPress; I've tried the various conversions or UTF8, and I still keep getting an error when I try to import the RSS feed from my old website:

    WordPress database error Data too long for column 'post_content'

    I've checked and double checked the settings in MySql and I just don't see any reason for a LONGTEXT field to choke on the length of the text being entered... it's not really all that long, it is in plain english, and I even tried stripping all of the HTML from it, all to no avail.

    Anybody have any idea why this is choking?

    Any ideas appreciated!

    Thanks in advance,

    --Jon

  4. kalana1338
    Member
    Posted 5 years ago #

    I am also having this problem.

    I thought I had fixed by the deactivating all plugins and then reactivating, but apparently not. It worked on one of my test posts, but not on another.

  5. kalana1338
    Member
    Posted 5 years ago #

    Changing from latin1_swedish_ci to utf8_general_ci solved the issue for me.

Topic Closed

This topic has been closed to new replies.

About this Topic