WordPress.org

Forums

[resolved] Database error (10 posts)

  1. Hannie
    Member
    Posted 8 years ago #

    Help i'm lost in installation! ;)
    I'm not a whizzkid ( if so i would have figured this problem out!) and trying to build my own blog on my site. But pfffffff the 5 min. installation is taking me now for 2 nights already!
    Here's my problem:
    I did everything step by step, created a database called WordPress
    Also created a user & all.
    Made an edit in the config.php and uploaded everything in the rootdirectory ( wich is httpdocs here)
    When i tried to open: http://www.middellaan.nl/wp-admin/install.php
    i got the message:

    We were able to connect to the database server (which means your username and password is okay) but not able to select the WordPress database.

    Are you sure it exists?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem

    I also tried http://www.middellaan.nl/httpdocs/wp-admin/install.php
    but than i got an error 404.

    What is it that i could possible do wrong? please help me, it's driving me crazy!
    If you have a possible answer please telle me step by step, since i'm totally new to all of this, and my english isn't that good!

    Thanks alot!

  2. moshu
    Member
    Posted 8 years ago #

    1. Never try this one:
    middellaan.nl/httpdocs/wp-admin/install.php
    "httpdocs" should never appear in URL
    2. Just read carefully the error message:
    Is the DB name WordPress or wordpress? Or WordPress? - they are not the same!
    3. Also, are you sure there is no username attached to it? What kind of site admin panel do you have? In my cPanel for example it is always "myusername_databasename"

  3. jamielu
    Member
    Posted 8 years ago #

    i just had this issue too. try entering the entire database name. if it has a bunch of underscores and characters, enter those too.

    it didnt work for me until i entered 'user_com_-_database' which is what Media Temple defaulted my database name too.

    the prefix should be in this format: 'user_'

    goodluck.

  4. Hannie
    Member
    Posted 8 years ago #

    Hi, it sure is WordPress. I also tried middellaan_Wordpress & Fenne_Wordpress. ( since Fenne is the username)
    did not work eighter

    Do you mean Plesk by site admin panel?
    whaaaaa where is that mistake,...... driving me crazy ;)
    Thanks for your help sofar

  5. moshu
    Member
    Posted 8 years ago #

    If you have Plesk, see http://www.tamba2.org.uk/wordpress/ - on the left, under Installation > Plesk.
    Maybe there is something helpful...

  6. leongky
    Member
    Posted 8 years ago #

    Help! I also have a problem with my database. I had been using wordpress for sometime, but when I tried to access it today, an error popped up.

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    I went to my control panel and checked to make sure my database is fine. I also went to check the wp_config.php which seems alright. Somebody help!

  7. moshu
    Member
    Posted 8 years ago #

    Somebody help!

    What about asking your host? If it worked earlier and suddenly it gives you a DB error - the first thing should always be to contact your host.

  8. Hannie
    Member
    Posted 8 years ago #

    I'm back! Saw that tutorial too before, and i did it just as they told. Hmmmm isn't this weird!
    I'm going to install it all again, and see what happens than. Thanks for your help and i will let you know when it's up & running!

    Thanks,
    Hannie

  9. Hannie
    Member
    Posted 8 years ago #

    YESSSSSSSSSSSSSS it's working! What it was? No clue.
    I gave it a new install and it's running!
    Thanks so much!

  10. moshu
    Member
    Posted 8 years ago #

    Glad you made it :) Happy blogging.
    (and thanks for setting the thread as resolved)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.