[resolved] database error - (10 posts)

  1. manfredeye
    Posted 9 years ago #

    Ive suceeded on getting manfredeye.com tranfered. Now Im tring to upload the database information so as all my comments/posts/etc will come up. Im getting this error.


    SQL query:

    CREATE TABLE wp_ak_popularity (
    post_id int( 11 ) NOT NULL default '0',
    total int( 11 ) NOT NULL default '0',
    feed_views int( 11 ) NOT NULL default '0',
    home_views int( 11 ) NOT NULL default '0',
    archive_views int( 11 ) NOT NULL default '0',
    category_views int( 11 ) NOT NULL default '0',
    single_views int( 11 ) NOT NULL default '0',
    comments int( 11 ) NOT NULL default '0',
    pingbacks int( 11 ) NOT NULL default '0',
    trackbacks int( 11 ) NOT NULL default '0',
    last_modified datetime NOT NULL default '0000-00-00 00:00:00',
    KEY post_id ( post_id )

    MySQL said: Documentation
    #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ENGINE=MyISAM DEFAULT CHARSET=latin1' at line 14

    If there is anyone that can help me get my database information back I would so appreciate it!

  2. manfredeye
    Posted 9 years ago #

    Is there any way that I can get some help please with this issue of regaining my comments/posts etc.? I have been waiting very patiently and doing many searches in the last 4hours.

  3. manfredeye
    Posted 9 years ago #

    I did find this plug in.

    WP-phpMyAdmin 2.8.2

    Provides phpMyAdmin from the WordPress admin console By Christopher Hwang.

    I have installed it but it doesnt seem to work for me. Has anyone else tried this?

  4. microkid
    Posted 9 years ago #

    Are you using phpMyAdmin to export? There might be a compitability problem between the MySQL version you're exporting from and the one you are importing the data into. Compare the two versions. phpMyAdmin has the option to export the data in compatible formats for different MySQL versions (it's on the export page).

    Hope that helps.

  5. microkid
    Posted 9 years ago #

    If you still can't figure it out, you can try using the export/import functionality within WordPress. It should be under 'manage' in your wp-admin section, or there's a plugin out there that makes it possible for older versions of WP.

  6. manfredeye
    Posted 9 years ago #

    well I did find that I was exporting from 4.1.21
    and importing on 4.0.16
    but there seems there should be a way to keep all my info and upload it to my new blog. I really cant loose all that info. Im lost...lol

  7. microkid
    Posted 9 years ago #

    No, it only has to do with the structure of the export, you won't lose any data.

    But again, check out the export/import functionality within wordpress, it is the best solution to your problem.

  8. manfredeye
    Posted 9 years ago #

    I tried the wordpress function and that didnt work for me as I didnt export from my last standing blog. Im trying to export from MySQL and I just found that there seems to be a bug in the system.
    Some may find this interesting.For me nothing there worked for me. Im still in fear of not being able to restore all my comments/posts

  9. manfredeye
    Posted 9 years ago #

    ok nobody BREATHE!
    I finally was able to upload my file to phpMyAdmin and was able to fill the database. Now like Id said there was a bug, dont know if that had anything to do with it but after reading many many posts here I did this:

    -- phpMyAdmin SQL Dump
    -- version
    -- http://www.phpmyadmin.net
    -- Host: localhost
    -- Generation Time: Aug 19, 2007 at 06:53 PM
    -- Server version: 4.1.22
    -- PHP Version: 4.4.4

    -- Database: 'your-DB-name'
    -- USER: 'your-username'
    -- PASSWORD: 'add-PW-here'


    -- Table structure for table wp_ak_popularity

    DROP TABLE IF EXISTS wp_ak_popularity;
    CREATE TABLE IF NOT EXISTS wp_ak_popularity (
    post_id int(11) NOT NULL default '0',
    total int(11) NOT NULL default '0',
    feed_views int(11) NOT NULL default '0',
    home_views int(11) NOT NULL default '0',
    archive_views int(11) NOT NULL default '0',
    category_views int(11) NOT NULL default '0',
    single_views int(11) NOT NULL default '0',
    comments int(11) NOT NULL default '0',
    pingbacks int(11) NOT NULL default '0',
    trackbacks int(11) NOT NULL default '0',
    last_modified datetime NOT NULL default '0000-00-00 00:00:00',
    KEY post_id (post_id)
    ) TYPE=MyISAM;

    -- Dumping data for table wp_ak_popularity

    I deleted:

    and it uploaded all my files.

    NOW,lol, I don't however have any access to the administrative dashboard! I so wish I knew what I was doing here! Ive been through most of the files and cant find out why this didn't create the admin dashboard access?!
    any suggestions?

  10. manfredeye
    Posted 9 years ago #

    Only because I have spent many many hours and days looking for answers for my issues and came across many unfinished questions I want to finish this error just in case it may help someone else.
    with that said:

    My problem lied with not using a fresh WP download. I deleted all my wordpress installation by using my ftp server. Downloaded a fresh wordpress installation. uploaded that to my ftp server. then activated it without issue. After the fresh install I THEN imported all my plug ins and any other extra perks. I believe that was what was holding me back along with also misinformation that was nestled in my old version from my last webhost.
    So now all is working and all I need do is get rid of the funky characters that are still lurking that weren't there before.
    I guess its all about carrying around old baggage!..hehe

Topic Closed

This topic has been closed to new replies.

About this Topic