Support » Plugin: MailPoet - emails and newsletters in WordPress » Database connection problem PHP 7 Maria 10 Synology

  • Resolved Hendrik57

    (@hendrik57)


    Just for the record and to help other users.
    I got a connection problem with mailpoet to the database.
    On the website of mailpoet is the described solution in Step 1:

    It should however be:
    define( ‘DB_HOST’, ‘127.0.0.1:3307’ );

    If you did not change the default port for Maria database 10 on a Synology. Maria 5 is there one the default port 3306. Localhost does not work for Maria 10. It should be 127.0.0.1 explicit.

    In my case there is no need to change php.ini as described in step 2.

    It seems like mailpoet forget to read the corresponding database access values in php.ini

    • This topic was modified 1 year, 1 month ago by Hendrik57.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author MailPoet

    (@wysija)

    Hi @hendrik57,

    Thanks for posting and sharing your solution with other users. Much appreciated! 🙂

    @hendrik57 – thanks so much for posting this. I just spent an hour trying to figure out why my DS918+ wouldn’t allow me to connect to the database. Ugh.

    Hi colleagues!
    Site on my device works with settings set up by default WP installation like:
    ‘localhost:/run/mysqld/mysqld10.sock’. Any modification of this string causes stop working of the site in general.
    Only this tuple starts site working again:
    ‘127.0.0.1:3307/run/mysqld/mysqld10.sock’
    However this recipy didn’t help to start MailPoet. 🙁
    Last update: replacement to “127.0.0.1:3307” is OK now! This is strange but this record was tried to be used sometime ago and it was not OK 🙁
    I’m happy again! 🙂

    • This reply was modified 10 months, 2 weeks ago by dittel.

    Hello,
    I’ve also an issue with mailpoet plugin on a Synology NAS.
    I tried localhost:/run/mysqld/mysqld10.sock and 127.0.0.1:3307/run/mysqld/mysqld10.sock
    Both run for all my site (main and plugins), but not for mailpoet that still cannot access the database.
    Mailpoet support answer was :
    “The first solution is to set the DB host as define(‘DB_HOST’, ‘127.0.0.1’); you shouldn’t also include the mysqlsock here.
    The second solution is to set the correct path for the pdo_mysql_sock, unfortunately we don’t officially support hosting on the type of set up you have. We’ll try our best to assist, but cannot guarantee it’ll work.”

    If someone find a solution, he’s the welcome !

    @algaillard, try the string as in my post above: ‘127.0.0.1:3307’ (no more).

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Database connection problem PHP 7 Maria 10 Synology’ is closed to new replies.