Support » Installing WordPress » database connection error

  • I’m at a loss. All of the settings are correct. No extra spaces, no deleted single quotes.

    The troubleshooting section of the install says to “Go to your MySQL client and type SET PASSWORD FOR ‘my_user’@’my_host’ = OLD_PASSWORD(‘my_pass’); and this may fix the problem.” but there’s no field in which to set password.

    Also, should the db have any tables?

    All help appreciated!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I assume that you are trying to install, is that correct? If you have been unable to connect to your database on installation, then there will not be any tables. WordPress must get connected first and then it will populate the database with the necessary tables.

    yes trying to install…

    so then any ideas why i’m getting a db connection error when all the settings (db name, user name, and password) are all correct?

    thanks in advance!

    Hmmm…is the DB_USER a member of the database with full privileges granted?

    Are you on a hosted server? Did you include the database prefix, if applicable? For example, my database is called “wp”, but my host required that I have “hostname_wp” prepended to the database name AND the database user name.

    (db name, user name, and password) are all correct
    Localhost? You might be in the 1% that needs to change that to the actual server name/uri

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘database connection error’ is closed to new replies.