• Database backup stopped working on several of my websites and I don’t know how to fix it. If I try to deactivate / activate Ithemes that can do the trick for a short period (maybe couple of backups) and then it’s not working again.

    Cron Schedules: itsec-backup – 86400 (1 day) – Backup.

    I activated Ithemes Debug and for Backup message is:
    {
    “all_sites”: false,
    “method”: 1,
    “location”: “/home/…/public_html/wp-content/uploads/ithemes-security/backups”,
    “retain”: 4,
    “zip”: true,
    “exclude”: [
    “itsec_lockouts”,
    “itsec_temp”
    ],
    “enabled”: true,
    “interval”: 1,
    “last_run”: 1576956816
    }

    Database method is Email only. I tried to uncheck Zip option, didn’t help

Viewing 7 replies - 1 through 7 (of 7 total)
  • MATT M

    (@beardedginger)

    Hi,

    Can you please enable the itsec debug and reset the scheduler to see if that corrects the issue?

    To enable the Debug menu in iThemes Security Pro you will need to add the code below to your wp-config.php file.

    define( ‘ITSEC_DEBUG’, true );

    Be sure to add the code above the “That’s all happy blogging.” line.

    https://ithemeshelp.zendesk.com/hc/en-us/articles/360018810613-How-Do-I-Enable-iThemes-Security-Debug-

    Thanks,

    Matt

    Debug is already enabled, how to reset the scheduler?

    MATT M

    (@beardedginger)

    Hi,

    Navigate to Security> Debug and under the Scheduler portion you will see a reset button next to ‘ITSEC_Scheduler_Cron’

    Thanks,

    Matt

    I Reset the cron.

    In Scheduler window:
    health-check 2020-01-08 11:47:11 (14 mins) daily
    purge-log-entries 2020-01-08 11:54:11 (21 mins) daily
    purge-lockouts 2020-01-09 11:27:11 (24 hours) daily
    clear-locks 2020-01-09 11:29:11 (24 hours) daily
    file-change 2020-01-08 11:35:11 (2 mins)

    In Notification Center window:
    digest 2020-01-06 11:46:51 2020-01-13 11:46:51 weekly
    lockout – – none
    backup – – none
    file-change – – none

    Lockout is set to none, but other should be active. I re-saved the Database backup options and Notification centre, but it’s still “none”.

    MATT M

    (@beardedginger)

    Hi,

    Thanks! Can you go to Security> Settings> Database Backup disable/reenable the module and then change the backup method to save locally and send the email?

    If you run the database backup manually from the Database Backup module, does the file save/ get emailed?

    Thanks,

    Matt

    Manually created backup works on one website, not on the other.

    I’ve done everything you asked, disable the backup, than enable it and saved as “save locally and send the email”.

    In Debug, Notification Center window on both websites:
    lockout – – none
    backup – – none
    file-change – – none
    hide-backend – – none

    On website that didn’t send the manual backup there is a backup as cron event, and there is a backup in the upčoad folder on the server.

    On the website that did send the backup there isn’t backup cron event.

    FYI

    According to the iTSec Pro 6.3.3 Changelog:

    Bug Fix: Backup event was not added when the WP Cron Scheduler was reset manually.

    Note this bug fix is not yet implemented in the free plugin.

    To prevent any confusion, I’m not iThemes.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.