Support » Fixing WordPress » Database Back Up Seems Blank

  • I am trying to migrate a WP blog to a subfolder of a WP blog on a different server. I have tried searching through the forums but can’t find a similar error. I do not fully understand SQL. Who am I kidding I have no idea about them.

    Here’s what I am trying to do. I was part of a political blog, plus I run my own. The political blog was race specific, and has moved on to other things and will be changing themes, focus, but we want to recreate an “archive” of it. Thus, we want to move it so it can be “as was”. I investigated the offline options, but multiple people were involved and it didn’t seem a viable option.

    I set up a new WP blog as a subfolder of my own at and got that running just fine.

    I had figured I could just use the WP Database backup and upload/import that and I’d get the content. But I can’t seem to make it work.

    I have run numerous backups in the last few days, and all of them seem to be blank.
    all that seems to be there is:
    # WordPress MySQL database backup
    # Generated: Wednesday 10. January 2007 16:44 PST
    # Hostname: localhost
    # Database: daytonvk_panel_b20
    # ——————————————————–

    That is all they contain. I was lax in doing backups so I don’t have any to fall back on, but I do know that in the past (6 months ago) there was TONS of other code and content in them.

    I then tried to download a version via phpMyadmin of the old host, (which I know has data in it as it is a huge file, but the tables seem to be individual files) and them Import it but then I get
    MySQL said:

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘./’ at line 1

    As I said I have no clue about databases, SQL, or phpAdmin. I have tried to follow the CODEX, but … well, it doesn’t seem to be so much me, but maybe the back up that is the problem. The one from the old host is not formatted right for the new host or something.

    I can’t seem to, or have no clue how to upload each table individually.

    What seems most likely to me, and again it may be all me, is that my WP DB BU is not working/downloading correctly, since it seems blank. I remember them being different before.

    I contacted my new host, but they aren’t that familiar with how wordpress works, and when I first migrated my blog there there, I was able to solve my own problems and explained it to them.

    Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • I got it.

    I’m sure you all know, but in case a newbie stumbles across this, you can’t move databases from one server to another, if they have different versions of software.

    Yep. That can cause what I call “interesting results”. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Database Back Up Seems Blank’ is closed to new replies.