WordPress.org

Forums

[resolved] Database and syntax errors after upgrade (2 posts)

  1. Linda513
    Member
    Posted 8 years ago #

    I just upgraded to wordpress 2.0.4 from 1.5. I installed everything and then imported my database info. I had to import it section by section because when I did the whole database at once it caused an error message saying It looks like you haven't installed wordpress yet.

    Everything looks great, except the categories, where I'm getting an error message about an unknown column. I've emptied the table, dropped the table, tried upgrade.php numerous times, reimported the data, nothing works.

    Now I'm trying to post to my blog and getting more errors. More unknown column errors and syntax errors.

    I'm assuming that the upgraded version of wordpress requires different database table columns and fields from the older version and when I import my data it doesn't fit into the new database properly. Is there any way to fix this, or do I have to delete all of my old data and start new?

    Thank you

  2. Linda513
    Member
    Posted 8 years ago #

    Never mind - I had wordpress installed on xampp and I upgraded it there. That worked fine, so I imported the localhost database into the "real" database, and now all is well. I still don't know why the upgrade didn't upgrade my "real" database, but thats for the experts to figure out.

Topic Closed

This topic has been closed to new replies.

About this Topic