Support » Plugin: Contact Form 7 Multi-Step Forms » Data not passing from each stage

  • Resolved vader7071

    (@vader7071)


    I am creating an online application. The overall form is 5 pages long. However, pages 1 and 2 are the ones with the most data. Pages 3 through 5 are just a couple of “yes or no” questions.

    I initially setup the application to go through all 5 pages. When I sent the email, nothing came through. I simply got the tags (e.g. [first-name], [last-name], etc).

    I went back and stepped through each page one at the time beginning at page 1. When I have it set to send the data from page 1 only, it comes through. Next I added page 2 to the list. When I send all the data from page 1 and 2 via page 2, the email contains all the data from page 2, but nothing from page 1.

    Here are some tags used on the pages:
    Page 1: [first-name] [last-name] [phone]
    Page 2: [travel] [yrs] [projects]

    On the mail tab for the form on page 2, I have tried using [first-name] and [multiform “first-name”]. Neither transmits the data in the email.

    I have followed the instructions in the FAQ, and my CF7 installation appears to be correct to their standards.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author webheadcoder

    (@webheadllc)

    From the FAQ:
    Make sure you have the multi-step tag on each and every form.

    I don’t see any multistep tag on step 2 of your form.

    Something like this needs to be on each form (replace the number of steps and the url):
    [multistep "2-5-http://webheadcoder.com/contact-form-7-multi-step-form-3/"]

    Thread Starter vader7071

    (@vader7071)

    I stopped the form at step 2 to make sure the information from step 1 was being transferred to step 2.

    Looking at the setup now, just look at it like a 2 step form.

    From step 1 to step 2, I lose all of the data from step 1, but step 2 comes through.

    Here is the email I received when I tested it:
    {step 1 – attempted both field setup, no data sent}
    [first-name]
    [middle-name]
    [last-name]
    [your-email]
    [multiform “phone”]
    [multiform “addy”]
    [multiform “city”]
    [multiform “state”]
    [multiform “zip”]
    [multiform “experience”]
    [multiform “education”]

    {step 2 – just garbage data}
    yes
    internet
    yes
    345
    3
    3dfgdfgsd
    dfgdgdf
    dgfdfgdfg
    dfgddfg

    Plugin Author webheadcoder

    (@webheadllc)

    Just making sure, do you have [multistep “2-2”] on the second step of your form?

    For mail, the correct tag is [first-name], no multiform needed.

    Thread Starter vader7071

    (@vader7071)

    I did have an error in my multistep line on page 1 and I corrected it.

    I did not realize I needed a multistep line on page 2 as well. I added the line as above and that solved the issue. Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Data not passing from each stage’ is closed to new replies.