Support » Plugin: LiteSpeed Cache » data-no-async=”1″

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Hai Zheng⚡

    (@hailite)

    You didn’t enable Load CSS Asynchronously currently right?

    You can try to exclude it from CSS Excludes or URI Excludes.

    Thread Starter miketica

    (@miketica)

    Load CSS Asynchronously was not enabled, correct.

    Excluding /wp-content/uploads/maxmegamenu/style.css from both CSS Excludes or URI Excludes does not help. I just tried it.

    Thanks

    Plugin Support Hai Zheng⚡

    (@hailite)

    CSS Excludes should work. If not, please check your log and paste the part that css file shows.

    If that file is from your theme file, yes that developer is correct, just append that data-no-async=”1″ to where it is coded.

    Thread Starter miketica

    (@miketica)

    So, the file is excluded, but I am not sure if it is the one causing issues. I tried excluding other CSS theme files as well, but nothing works. When I activate Load CSS Asynchronously, the menu looks like this on desktop:

    https://prnt.sc/o3ulsb

    The mobile hamburger menu icon is showing (it’s not supposed to), the flyout menus are not displayed correctly and neither is the top bar.

    So, I am not sure what I can do to make it work. Before, I was using criticalcss.com with Autoptimize and the Critical CSS was generated without any errors at a click of a button, on the same website. I am not comparing anything, I am just trying to narrow down the issue so I can make it work.

    Thanks,
    Mike

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please confirm that you have purged all , including CCSS (if you have enabled) after you add it into Excluding box.

    Also , could you please provide the report number ?

    Best regards,

    Plugin Support Hai Zheng⚡

    (@hailite)

    Please define nothing works. Did you check the source code? Is the CSS you tried to exclude excluded?

    Does log tell if its excluded or added to optimization queue?

    Thread Starter miketica

    (@miketica)

    Hi guys,

    This is the report number:

    Report number: MGFQFAXM

    Report date: 06/21/2019 15:54:47

    This in the log file where the file shows:

    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] start
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude style.min.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude /wp-content/uploads/maxmegamenu/style.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude dashicons.min.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude mobile-header.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude layout-max-low.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude layout-max.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude layout-below-max.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude layout-small.css
    06/21/19 09:01:50.408 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude wc-small-screen.css
    06/21/19 09:01:50.409 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude cubeportfolio.min.css
    06/21/19 09:01:50.409 [162.158.106.130:23878 1 ZsG] [Optm] _handle_css bypassed exclude 13332-layout-partial.css

    (these are not all the files I excluded, just a few of them)
    I am not sure if I am excluding the correct file. What I did was to set Disable All Features On, navigate to the website in an incognito window, and get a list of the CSS and JS files (using the Blue Button extension).
    Then, I logged in into Cloudflare, disable all the Auto Minify features (to be sure) and cleared the cache.
    Then, I loaded the Litespeed plugin settings, enabled CSS Async and performed a Purge All.

    The website layout is still broken. Using the CSS files I got from the Blue Button extension, I tried excluding theme files (from CSS excludes) one by one to see if it changes anything. It does not, the desktop menu layout is still broken.

    Let me know if I can provide anything else to make things easier.

    Thanks,
    Mike

    Thread Starter miketica

    (@miketica)

    So, I guess I’ll have to look somewhere else for a working solution until the CCSS of the plugin is improved?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Apologize for late response.

    Please try temporarily disable the CloudFlare during the debug process to eliminate any possible interfering.

    I see some feature like rocket loader are enabled , that might interfere.

    If you only enable CSS async and set CCSS generation in background or disable it , will it work ?

    Best regards,

    Thread Starter miketica

    (@miketica)

    Hi,

    I have turned Cloudflare development mode on.
    CSS generation is set to background.
    It still breaks the menu on the website.

    Thanks,
    Mike

    Thread Starter miketica

    (@miketica)

    I saw in other topics that you plan to add some CCSS improvements in v3.0.
    Is there an approximate release date?

    Thanks

    Plugin Support Hai Zheng⚡

    (@hailite)

    Yes those improvements are already done in v3.0 branch.

    v3.0 Should be able to release this year.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘data-no-async=”1″’ is closed to new replies.