Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Data error in Analytics The response is not a valid JSON response.

  • Resolved uniquesrilanka

    (@uniquesrilanka)


    I don’t know what should I do with is ” Data error in Analytics The response is not a valid JSON response” message .. my all plugins and theme up to date.. please advice me on what to do..
    we site is https://srilankatourstravels.com/

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out, hopefully we can assist. In other cases whereby users encountered this notice there have been plugins and also hosting Web Application Firewall rules resulting in the same notice. Firstly before troubleshooting can you share the following:

    1. Has this started to occur for you just recently?
    2. What browser console errors do you see on the same screen as this notice?
    Thread Starter uniquesrilanka

    (@uniquesrilanka)

    Thank you for helping me…

    1) Has this started to occur for you just recently?

    Answer : Yes.. I don’t remember the date but I think less than thee week.. i didn’t update elementor new version due to some element issue so I thought because of the plugin update then after fix the element I updated the plugin but I notice still error message on Dashboard. but its only show on the dashboard only. Search counsel & Analytic sections not showing error

    2) What browser console errors do you see on the same screen as this notice?
    Answer : I see this error only dashboard on Sitekit. (as I understand the question)

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for providing an update. Based on the information provided lets attempt some plugin troubleshooting. It might be useful to know whether you encounter the same message after attempting the following:

    1. Login to your site from a Chrome browser incognito window
    2. Install and activate the Health Check & Troubleshooting plugin.
    3. Navigate to “Plugins > Health Check & Troubleshooting > Troubleshoot”.
    4. From the same screen click on the “Available Plugins” tab at the top right and then click on the “Enable” option next to “Site Kit by Google”
    5. Attempt to setup Site Kit once more

    You can exit troubleshooting mode afterwards.

    Thread Starter uniquesrilanka

    (@uniquesrilanka)

    thank you for your advice… I did as you told me but seems everything fine..it didn’t help me. so I have attached images here please check them
    image 1
    image 2
    image 3
    image 4
    image 5
    image 6

    please advise me what I can do

    Plugin Support James Osborne

    (@jamesosborne)

    Apologies for the delay, and many thanks for your attempts so far. Based on the screenshots provided it looks like there are additional plugins active when performing the same checking using the Health Check & Troubleshooting plugin. Were those screenshots before or after your performed a check?

    As this only seems to occur within the Analytics dashboard I’d be happy to check for any possible conflicts with your current environment if you’d like to share your Site Health information. You can share privately using this form.

    Plugin Support James Osborne

    (@jamesosborne)

    As we didn’t receive a response I’ll mark this as resolved. Feel free to open a new support topic if you continue to encounter issues, or reopen this topic and we’d be happy to assist.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Data error in Analytics The response is not a valid JSON response.’ is closed to new replies.