Support » Plugin: MailChimp List Subscribe Form » : Data did not match any of the schemas described in anyOf.

  • Resolved tuffstudio

    (@tuffstudio)


    getting “: Data did not match any of the schemas described in anyOf.” error when submitting form

    plugin 1.5.2
    wordpress 4.6.1

    error message

Viewing 15 replies - 16 through 30 (of 30 total)
  • The root cause of this problem is that the following specific MailChimp API call fails consistently and as a result the rest goes south.

    Secondly, the error handling in the PHP source for this unusual case could be better so that you do not get these PHP Notice: Undefined variable: field_name and Notice: Array to string conversion

    => These are the details of the API call:
    Source: \plugins\mailchimp\mailchimp.php
    PHP Function: function mailchimpSF_signup_submit()

    HTTP GET
    https://us2.api.mailchimp.com/3.0/lists/00f7b809c5/members/7d8d7b83d44adfe4fd0868008e2d8732?fields=status

    HTTP HEADER ‘Authorization’
    apikey XXXXXXXXXXXXXXX-us2

    HTTP RESPONSE:

    {
        "type": "http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/",
        "title": "Resource Not Found",
        "status": 404,
        "detail": "The requested resource could not be found.",
        "instance": ""
    }

    => Remarks:
    – I have removed all merged fields from that MC List and the error still occurs.
    – Is it possible that parts of the new API are not accessible for Free MC accounts?

    I hope this gets fixed by Sep 15th because then the old API does not work anymore,
    Rolf.

    Thanks so much, everyone!

    Narrowed it down- I was able to replicate the issue when I upgraded to PHP 7.0 (was on 5.3). I’ll be sure to pass this over to the plugin developer for a fix. In the meantime, as a workaround y’all can downgrade your PHP versions and it should work just fine.

    I’ll update the thread when there’s a fix. Thanks again for all your help and examples!

    Best,
    Garnet

    • This reply was modified 5 years, 4 months ago by mcsupport.

    Great to hear you have found a fix, but will add my voice behind a drive for a speedy bugfix please, because for us, and i suspect for others, downgrading php is not an option- we are on this version for good (and very hardcoded) reasons!

    thanks

    @t22james definitely understandable. I know downgrading php versions is not ideal- another thing you can try for now is to just use the MailChimp embed code instead of the plugin until this gets resolved.

    I don’t have an ETA as to when this issue will be resolved, but rest assured that we’ll push a fix out just as soon as one becomes available. Thanks for your patience in the meantime!

    -Garnet

    Hi Garnet,

    Just wanted to put my voice behind this also, disappointed to see the official Mailchimp plugin not compatible with PHP7. I’ve just signed up for Mailchimp to add this to my site, to learn that now I can’t. Please get it fixed ASAP, as downgrading PHP isn’t an option for us.

    Thanks!

    Darren

    hey @mcsupport- any update on this perchance? has it made it into a release sprint or are we still drifting in neverland…

    cheers!

    I would like to receive an update about this issue as well!
    Downgrade of PHP is not an option for us as well.

    Hey y’all,

    Quick update – we’ve got a fix in and we’re QA-ing it now. I’ll update once more when I get more information. Thanks all for your patience!

    Best,
    Garnet

    Thanks Garnet!

    I have just noticed that we are running into the same problem

    Plugin Version: 1.5.1
    WordPress verison : 4.6.1

    Mine is in a sidebar widget.

    Mailchimp, any news on this? You seem to have gone silent on us here. ๐Ÿ™‚

    Cheers!
    =C=

    Hey @calevans,

    Thanks for posting! A fix is being QA’d as I mentioned yesterday, and I’ll be sure to update the thread once I get more details. I would recommend reading through the entire thread- there’s some details on what’s causing the issue and a workaround.

    Let me know if you have any questions!

    Best,
    Garnet

    totes sorry. I did not see page 2 of the thread. ๐Ÿ™‚

    My fault.

    Lookin forward to the patch.

    Cheers!
    =C=

    Any updates on this?

    I have 1000’s of customers using your plugin and none of them are collecting emails… Do I need to recommend another plugin or is there a fix coming soon?

    I’m really surprised that so many plugin developers are getting caught off guard by PHP 7 – WordPress has fully supported it for more than a year!

    Please respond one way or another. ๐Ÿ™‚

    Have there been any updates on this?

    Hey yall,

    An update was pushed through just a few minutes ago that should resolve this! Please feel free to update the plugin and test things out. Let me know if y’all see anything out of the ordinary.

    Thanks everyone for the information and your patience!

    Best,
    Garnet

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘: Data did not match any of the schemas described in anyOf.’ is closed to new replies.