• In this, my most recent attempt to Install wp, I’ve reached the wp-admin/config.php page, where I’m asked to give database name, user name, password, database host, and prefix.

    I’ve given correct answers to those questions and checked with my server, the host is localhost. But I’m still getting an error message that I can’t connect to it.

    Thank you in advance for any help.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Did you assign your wordpress user full permissions on the wordpress database when you created it?

    @blabberpen can you please check if the newly created user is linked and has all permission to the appropriate database.

    Keith

    (@keithdriscoll)

    @blabberpen I can see that you are using Bluehost as your host. Why don’t you just use the one click installer? If you still want to continue with manual install, as others mentioned, you probably need to create a “user” and add the permissions from within the database section of your Bluehost control panel. If you continue to have trouble with that I am sure a quick call to Bluehost would help you resolve your issue as I have had very positive experiences with their support techs.

    Thanks for your help. I did make sure the user – yours truly – has all privileges. I still seem to be stuck at same spot – Error making databases connection. I noticed this time that there were a few databases that I never sought to have, as well as users – usually with same name as that database – that I never sought. To what oage might I go for one-click install. I must admit I get confused my number of options presented at once.

    I noticed this time that there were a few databases that I never sought to have, as well as users – usually with same name as that database – that I never sought.

    That seems a bit odd. If there are databases you did not create in your hosting account, and users you did not create and authorize yourself, then you may want to contact your hosts support group for advice.

    Bottom line: If the information in your wp-config.php matches exactly your WordPress database name, database user, and database user password, there should be no error in connecting to the database.

    Keith

    (@keithdriscoll)

    Sorry for late reply,

    As @claytonjames mentioned, there should not be any DB’s that you are not aware of. Sometimes though, this happens when people install scripts such as WordPress, Joomla, Forum software, etc. that require a database but you would probably be aware of any software installs. Just be be sure you know what you are deleting before you 86 any databases.

    As far as your DB username, if you want to try continuing with the manual install before trying an automated install, I would suggest creating a new DB user with NO spaces in the name or use an underscore instead of blank space. Sometimes spaces in names can cause issues.

    I use Bluehost all the time for both myself and clients and find that their control panel is quite intuitive. As soon as you login you should be brought to your CP. Scroll down to “Websites” section and you should see “1 Click Installs”. Once there WordPress is the first option under “Popular Scripts”.

    There are many security benefits to a 1 click installer that most beginners may not realize. The Bluehost installer is very good at creating a secure installation.

    Hope this helps and good luck!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.