Support » Plugin: Subscribe2 - Form, Email Subscribers & Newsletters » {DATE} notation not in Site language

  • Resolved Henk Barreveld

    (@henk-barreveld)


    Hello,

    With much pleasure I am using the Subscribe2 plugin – but there is something that I think could be improved.

    My website is in the Dutch language (Nederlands), but for the back-end I prefer English; mainly because all my communication about WordPress is in English.

    so:
    – In WP Dashboard > Settings > General, Site language is “Nederlands”
    – In WP Dashboard > Users > Your profile (for the administrator), Language is “English (United States)”

    I noticed that with the above settings the {DATE} (and possible also {TIME} – not sure) keywords in message templates are presented in English in the email messages sent. If I change the administrator language to Dutch as well, the Dutch language is used for the DATE keyword.

    Because this is about messages sent to users of a Dutch website, it seems more logical to me that for these keywords the Site language would be used instead of the administrator language.

Viewing 5 replies - 1 through 5 (of 5 total)
  • mattyrob

    (@mattyrob)

    @henk-barreveld

    Subscribe2 should use the date and time options as defined at the bottom of the Dashboard > Settings > General page.

    Henk Barreveld

    (@henk-barreveld)

    Thank you for your reaction.

    I think you misunderstood. The options at the bottom of the Dashboard > Settings > General page are about the date and time FORMAT but that is not the issue. My message is about the date and time LANGUAGE.

    For example: my date setting on the Settings page is ‘j F Y’. Underneath the date setting box is a preview example:
    – when the back-end language (administrator account language) is English, it says 23 March 2018
    – when the back-end language is Dutch, it says 23 maart 2018

    At the front-end, if the site language setting is Dutch, you always see the date represented as 23 maart 2018 (in the post entry-meta, for example), independent of any administrator account language setting.

    In the email messages produced by Subscribe2 this is not the case. The date is correctly in the format ‘j F Y’ (as you wrote), but incorrectly (I think) in the language of my administrator account instead of the site language.

    I hope this is clear now?

    mattyrob

    (@mattyrob)

    @henk-barreveld

    I understand much better now from the explanation – the formatting is fine but the names of the months are not localised.

    So, to get a bit more information, the site is in Dutch, but the author of the post is logged into the WordPress admin area with a preference setting to use American English as the admin language.

    That combination results in the dates in the emails (presumably per-post notifications) to be in America English rather than Dutch. Is that correct?

    mattyrob

    (@mattyrob)

    @henk-barreveld

    I’ve done some investigating and can re-produce this issue. I’ve also created a fix and committed it to my fork of Subscribe2 here:
    https://github.com/mattyrob/subscribe2

    Henk Barreveld

    (@henk-barreveld)

    @mattyrob

    You are a hero! I installed and tested your fix: problem solved.

    Thank you very much!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘{DATE} notation not in Site language’ is closed to new replies.