Support » Plugin: Bitcoin and Altcoin Wallets » Dashed_Slug_Wallets_Coin_Adapter_RPC->get_balance() failed with status=”0″ and e

  • I am getting this error “Dashed_Slug_Wallets_Coin_Adapter_RPC->get_balance() failed with status=”0″ and error=”Failed connect to 145.14.145.227:0; Connection refused” while trying to install bitcoin wallet on wordpress on my freehosting site . How can i test what is wrong , and what setting i am using

Viewing 1 replies (of 1 total)
  • Plugin Author dashed-slug.net

    (@dashedslug)

    Connection refused means that your machine at 145.14.145.227 does not have its port open. I see that you are attempting to connect at port 0, which is not correct. The RPC port setting on the adapter should match your rpcport= setting in your bitcoin.conf. This process is detailed in the video at https://www.youtube.com/watch?v=_dbkKHhEzRQ

    You can check if your RPC port is open to the internet using a tool such as https://www.yougetsignal.com/tools/open-ports/ Keep in mind that your server’s firewall might need tuning. Some server hosts have firewalls that are too restrictive.

    Once you get the RPC port open, the next step is to setup authentication, via the rpcuser= and rpcpassword=, or alternatively, rpcauth= lines.

    And finally, if your wallet is encrypted with a passphrase (as it should be), you will want to enter the passphrase in your coin adapter settings, either once, or once every time you want withdrawals to process. This is up to you, depending on the level of security you want. Consult the documentation for details.

    If you find the process too hard, you also have the option to install one of the cloud wallets.

    kind regards

Viewing 1 replies (of 1 total)
  • The topic ‘Dashed_Slug_Wallets_Coin_Adapter_RPC->get_balance() failed with status=”0″ and e’ is closed to new replies.