Support » How-To and Troubleshooting » Godaddy free hosting – Dashboard / Admin broken

Godaddy free hosting – Dashboard / Admin broken

  • Fresh install of WordPress 2.8.
    Using Godaddy.com free economy hosting.
    Website looks fine: http://www.21105oakdale.com.
    I can login in to dashboard admin fine.

    However, it appears the dashboard has no formatting – ie, it appears it is not calling the css correctly.

    (I’m a novice but have somewhat of an understanding of this stuff).

    I’ve tried reinstalling the wp-admin and wp-includes folders.
    I’ve tried resetting the cache and cookies.
    I’ve tried refreshing the permalinks.

    All of the above were tips I found on the WP forums.

    Unfortunately, none has worked thus far.

    Any tips?

Viewing 15 replies - 1 through 15 (of 101 total)
  • Just figured out it works fine with IE 7.0 but not firefox 3.0.11.

    Wonder if a firefox plugin is the problem?

    Either way, I guess I’m stuck with IE for now.

    I’m having the same problem. Using IE8 fixed it, but using latest versions of Firefox and Chrome won’t work.

    Ok, I take that back. Now the dashboard looks fine, but it still doesn’t have functionality. For example, on the widgets page I can actually move the elements around. Here’s the error IE gets:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
    Timestamp: Mon, 15 Jun 2009 17:03:09 UTC

    Message: Syntax error
    Line: 24
    Char: 1
    Code: 0
    URI: http://stanfordlawyers.com.previewdns.com/blog/wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=d24248fe4b0cd62086633fd42ef1019b

    Message: Object expected
    Line: 802
    Char: 11
    Code: 0
    URI: http://stanfordlawyers.com.previewdns.com/blog/wp-admin/widgets.php

    Message: Syntax error
    Line: 56
    Char: 1
    Code: 0
    URI: http://stanfordlawyers.com.previewdns.com/blog/wp-admin/load-scripts.php?c=0&load=hoverIntent,common,jquery-color,jquery-ui-core,jquery-ui-sortable,jquery-ui-draggable,jquery-ui-droppable,admin-widgets&ver=2203e0189e7d540d81024839750b0838

    I’m having the exact same issue with GoDaddy.com free hosting. Tried everything. I’ve found 2 or 3 threads on the net regarding this exact issue, and they all just end after 3 or 4 posts…. with no solution. This is a real issue. You can only use the 2.8 wp-admin on IE8 (Yuck!) otherwise, Safari, Chrome, Firefox it looks like it’s missing the CSS.

    One blog mentioned changing all the permissions to the uploaded wordpress install to 755, which I did, but it didn’t change a thing. He had 3 comments on his blog, the user said he still couldn’t get it to work, and the only suggestion given was to flush the browser cache (duh!).

    Any help? BTW, I’ve also tried 2.8.1 beta 1 – 2.8.1 beta 2 – 2.8.1 nightly ……none work, so I doubt the WP devs are aware of this.

    Did you try to switch of your gear plugin?

    That did the trick for me – and btw I had the exact same problem and I’m not using Godaddy.

    This is a fresh install. Are you talking about Google Gears, to speed up the backend? Don’t you need to enable it first to use it? What do you do to “switch the gear plugin?”


    Yes it’s google gears, I’m referring to.

    And yes, if you haven’t enabled it, that can’t be causing your problems.

    Has there been any progress on this problem? I’m still having the problem, even after the 2.8.4 update. I don’t have Google Gears installed. The website does not work correctly in Firefox or Chrome. IE seems to display the pages correctly, but still has a few problems (can’t move widgets around).

    I solved the problem for dashboard not using/finding CSS setting permissions for load-styles.php (in wp-admin directory) to 0755.

    I solved the problem for managing/moving widgets setting permissions for widgets.dev.js (in wp-admin/js directory) to 0755.

    Has anyone found a solution to this problem? My admin screens are borked up since I upgraded to 2.8.4, and I cannot seem to find a solution.

    Free web hosting just does not work well with WordPress because the web host inserted ads, tracking code, and/or frames mess things up.

    Has anyone found a solution to this problem? My admin screens are borked up since I upgraded to 2.8.4, and I cannot seem to find a solution. [2!]

    Not using free hosting.



    Hello, excuse for my english. The problem on admin interface is in the free hosting solution of godaddy, infact godaddy web server append this code at end of the page:
    </iframe></noscript></object></layer></span></div></table></body></html><!– adsok –>
    <script language=’javascript’ src=’https://a12.alphagodaddy.com/hosting_ads/gd01.js’></script>

    The procedure of dynamic include, in the admin interface, of CSS and JS produce a file with the code added from godaddy webserver, the browser interpreter fails to recognize the mime type.
    The solution is to modify the script that load dynamically JS and CSS, in the file: wp-includes/script-loader.php.
    The admin interface is more slowly but work fine …

    That’s all!

    How exactly are you modifying the script, Stefano?



    the script was modified in 2 points.

    First point the script load JS:

    // **********************************************
    // Clean for godaddy free hosting
    $st_data = file_get_contents( $src );
    $st_data = substr( $st_data, 0, strrpos( $st_data, ‘</iframe>’ ) );
    echo “<script type=’text/javascript’>\n”;
    echo $st_data;
    echo “</script>\n”;
    // **********************************************
    // echo “<script type=’text/javascript’ src='” . esc_attr($src) . “‘></script>\n”;

    Second point the script load stylesheet:

    // **********************************************
    // Clean for godaddy free hosting
    $st_data = file_get_contents( $href );
    $st_data = substr( $st_data, 0, strrpos( $st_data, ‘</iframe>’ ) );
    echo “<style type=’text/css’ media=’all’>\n”;
    echo $st_data;
    echo “</style>\n”;
    // **********************************************
    //echo “<link rel=’stylesheet’ href='” . esc_attr($href) . “‘ type=’text/css’ media=’all’ />\n”;

    In all 2 points, the line commented was originally in the source of wordpress 2.8.4.
    I had commented that and i had added the code over that.

    The JS or stylesheet was loaded into $st_data var ($st_data = file_get_contents( $href );), then cleaned for the tag added by godaddy ($st_data = substr( $st_data, 0, strrpos( $st_data, ‘</iframe>’ ) );) and finally included in the output page (echo $st_data;) with the apposite start and end section tag.

    This code work fine for me.
    I hope that work fine for all.

Viewing 15 replies - 1 through 15 (of 101 total)
  • The topic ‘Godaddy free hosting – Dashboard / Admin broken’ is closed to new replies.