Support » Fixing WordPress » Dashboard Widgets not remembering location

  • Resolved Matthew Meyer

    (@osarusan)


    After upgrading to WP3, all my dashboard modules/widgets locations reset. That’s not such a big problem except that I can’t put them back to where they were! That is to say, every time I log in to my dashboard, the widgets reset to their default locations. Even when I move them to a new place, next time I load the Dashboard, they all move back to their original spots. Why is this happening?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Try clearing out the cookies you have stored for you site, login again, and see if behaviour now returns to normal.

    If that doesn’t help, open up your wp-config.php file, change the salt and nonce keys and once again login (changing them will require you to login again), and see if that helps.

    Hmmm, tried both of those. Even tried using a different web browser, but still the modules reset their locations. Any other ideas?

    Create a new user account, doesn’t necessarily need to be an admin.

    Login with the new account and see if widgets then save positions.

    I just tried, but no luck.

    Even with the new user, the widgets won’t save positions.

    Any other ideas? I just tried reinstalling wordpress again, to no luck.

    is this a connected problem? I can’t reorder widgets in my sidebar with wp3. And I can only drag one into the inactve area.

    @lynandlloyd

    is this a connected problem? I can’t reorder widgets in my sidebar with wp3. And I can only drag one into the inactve area.

    No i believe this is a seperate type of problem, unless you also have problems with Dashboard widgets not remembering their positions.

    @osarusan

    Any other ideas? I just tried reinstalling wordpress again, to no luck.

    Try another browser and/or another PC, simply to rule out a browser/pc issue (only need be temporarily just to confirm if the problem is still present)

    @mark

    I’ve done that. Tried it on Windows and Linux, 3 different PC’s, using Chrome, Firefox and IE.

    I just updated to 3.0.1 and still no help.

    I noticed that I *can* change the columns to single/double/whatever, and the checkboxes to remove certain widgets do work. The only thing that isn’t working is reordering the widgets and changing their location. Rather, I can move them around freely, but it never remembers their new locaiton.

    Running out of ideas, perhaps enabling debug will prompt an error or two to appear which might give us some clues, see here on how to enable debugging..

    http://codex.wordpress.org/Editing_wp-config.php#Debug

    EDIT: Does this sound like the same problem?
    http://core.trac.wordpress.org/ticket/13424

    Mark,

    Thanks, that was definitely the same problem!

    I followed the advice on the page and deleted my wp_meta-box-order_dashboard table, and then it worked right away. Thanks for your help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Dashboard Widgets not remembering location’ is closed to new replies.