Support » Fixing WordPress » Dashboard Menu Hover Error!

  • Resolved tsoto111

    (@tsoto111)


    Today I downloaded the latest version of wordpress and set up the installation on my local machine. I am using MAMP if you have to know. After setting up the default WordPress CMS my Dashboard sidebar menu loads all wonky. I checked older versions of wordpress sites that I manage and the samething is happening.

    I have attached a screenshot here.

    The menu items get pushed on top of eachother after hovering through them. If I hover back down they sometimes snap back into place.

    In the new installation I have installed no new plugins so those can’t be the issue. It is a pure default installation. The browser I am using is Chrome.

    There are no error messages in the console. Any ideas? Is there some jQuery script that Chrome doesn’t support anymore in the WordPress core files? HELP PLEASE!!!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Chrome 45 has a rendering bug. There is a ticket open on Chrome’s bug tracker about this issue, hopefully they will fix it soon.

    In the meantime, here is a workaround to eliminate the issue in Chrome.

    – Go to chrome://flags/#disable-slimming-paint
    – Enable the “Disable slimming paint” option.
    – Ensure that the “Enable slimming paint” option below it is not turned on.
    – Relaunch Chrome.

    When you’re done, the final result should look like this:
    https://cloudup.com/cddYghY8fBd

    This will disable the problem code in Chrome and allow the menus to render normally.

    Yup, mhmmm God Bless… I knew the internet gods were up to something. Appreciate the help brotha!

    Samuel… You are a saint! God Bless you Saint Samuel the scuba diver.

    This has been driving me crazy all day! Thanks so much Samuel 🙂

    @otto Much appreciated! Figured it had to be a Chrome bug but couldn’t figure out what was causing it. The fix you outlined works perfectly.

    Thanks Otto!

    Thanks for knowing the answer to this, Samuel. And thanks Google for making this the #1 search result for “WordPress dashboard menu”. Now, please fix Chrome.

    Thanks for addressing this @tsoto111 and sharing the solution @otto.

    Thanks Sam!!!!

    whoa.. This fixed the problem for me too. Thx Sam..

    Just as an update to everyone, I didn’t implement the fix and Chrome has fixed the issue. I came into the office today and no wonky hovers.

    Cheers,
    – Tavo

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @tsoto111

    For reference, while the Chromium project has indeed created a fix, it has not been released yet; it was only created 5 hours ago.

    The issue still exists in all Chrome browsers of version 45 or higher.

    You may see it work correctly sometimes, however the nature of the bug is slightly random. If your menu is longer than the page (goes past the scroll), then you are far less likely to see the issue, and the issue will instantly disappear for most users when you scroll. This is not a fix, it’s just part of the oddities of the bug.

    The current state of the problem in Chrome is this:
    – The problem was found and an actual fix has been created.
    – It will be released to Chrome Canary sometime in the next 24 hours.
    – Chrome 45 will probably NOT receive a fix. The current push is to get the fix merged into Chrome 46 (currently on the beta channel). Now, this MAY change. It’s a bit hard to say, as this is a breaking regression, and sometimes patches do get fast tracked.
    – Chrome tends to release stable builds on roughly 6 week schedules. Meaning that if the current status quo holds, the fix would make it into Chrome Stable roughly the second week of October.

    this is unnacceptable waiting 6 week for a bug fix?
    just uninstall chrome is the solution at the moment.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    What about Otto’s solution above?

    Thank you Andrew, after disable slimming paint in my chrome the bug it’s gone.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Dashboard Menu Hover Error!’ is closed to new replies.