Support » Plugin: Events Manager » Dashboard inaccessible

  • Resolved jelly_bean

    (@jelly_bean)


    I have inherited a site that is using an old version of this plugin (Version 5.5.6) and it is causing issues with the admin dashboard. If I rename the plugin to deactivate it via ftp then the dashboard works.

    I’ve tried disabling all other plugins and enabling Events Manager to see if there is a conflict, but when I activate Events Manager with no other plugins the dashboard is inaccessible and I get this error message.

    PHP Fatal error: Uncaught Error: [] operator not supported for strings in /public_html/wp-content/plugins/events-manager/classes/em-events.php:69

    I tried deleting the old plugin and installing the latest version, but that doesn’t work either. The dashboard becomes inaccessible when I activate it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Had to rename Events Manager plugin to disable it, update WordPress and each plugin individually and then update the Events Manager plugin to fix.

    TreeTrail

    (@aprilschmitt27)

    I was locked out of my dashboard last night too. But it was after the WordPress upgrade. I haven’t upgraded Events Manager since v2.6.7.2 (as I’m waiting for the date issue to get figured out). The web-host totally cleared the site’s cache and I was back into the dashboard immediately.

    Plugin Support timrv

    (@timrv)

    Hello @aprilschmitt27 The Date/Timezone issues should be fix with the latest Version of Events Manager (Not Pro) should be able to fixed it.

    As a recommended precaution, It’s always best to test things on a Staging Site or making a sitebackup before making any updates

    TreeTrail

    (@aprilschmitt27)

    Hello @timrv. I mistakenly thought that the EM update to fix the Date/Timezone was not ready yet. Great news.

    Very good advice. I do always take those 2 precautions. What happened was, my host had added a setting to automatically initiate WP Core updates. They had sent a warning notice, but I didn’t react fast enough. After that uncontrolled experience, I added “define( ‘WP_AUTO_UPDATE_CORE’, false );” to my wp-config file. So I have time to test first.

    Thanks for supporting this fabulous plugin. It is the most important of the 37 that we’re using. My users love it!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.