Dashboard fail to fetch_rss (6 posts)

  1. rafibodill
    Posted 9 years ago #

    Please, help.
    I've installed a clean install of wordpress 2 on my Linux/CentOs/cPanel server, running PHP5, and the Dashboard fails to load completely, when loggin-in, it looks like this:

    I've commented out line 18 in /wp-admin/index.php which is:
    $rss = @fetch_rss('http://feeds.technorati.com/cosmos/rss/?url='. trailingslashit(get_option('home')) .'&partner=wordpress');

    And it works fine! What's the problem?

  2. alQpr
    Posted 9 years ago #

    I have just had to deal with the same problem (ie Dashboard failing to load until the @fetch_rss lines were commented out) and don't see why it is identified as "not a support issue".

    The question is "What's the problem?" meaning "Why does @fetch_rss fail on some hosts?"

  3. CharlieSmith
    Posted 9 years ago #

    I'm experiencing a similar issue. In my own case, a new installation of WP has worked fine for a few weeks, until it suddenly took 90 seconds to log in. Removing the calls to fetch_rss has reduced the login time to a few seconds, as above.

    I've timed an individual call to fetch_rss at 30 seconds exactly, which suggests that something somewhere is failing, then timing out. But my experience with this is to limited to progress it much further, at least at the moment.

    Please someone! Any help?

  4. CharlieSmith
    Posted 9 years ago #

    I've now done a bit more diagnosis, and the time out occurs at line 1145 in class-snoopy.php on a call to fsockopen to host feeds.technorati.com:80 - the error code is simply "connection timed out", and the timeout value is indeed 30 seconds.

    There seems to be no obvious reason why this code shouldn't work, so I'll take it up with my hoster - but in the meantime, if anyone has any ideas as to what is causing this, shout out!

  5. Chris_K
    Posted 9 years ago #

    Technoratti is dog slow?

  6. davidchait
    Posted 9 years ago #

    the technorati feeds could be having problems, the fsockopen might not be respecting the timeout, the php timeout on your host might be short, etc. lots of reasons. best to just disable the dashboard rss stuff. ;)


Topic Closed

This topic has been closed to new replies.

About this Topic