The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Dashboard Error - rss-functions.php (8 posts)

  1. Jacob
    Posted 11 years ago #

    I recently installed WP 1.51 onto my site. The previos version installed was 1.5. Since the upgrade, my Dashboard has had an error involving the rss-functions.php. I tried deleting and reuploading rss-functions.php, but it didn't help. Here is the error:

    Warning: main(/home/aurexoul/public_html/jacob/wp-includes/class-snoopy.php): failed to open stream: No such file or directory in /home/aurexoul/public_html/jacob/wp-includes/rss-functions.php on line 370

    Fatal error: main(): Failed opening required '/home/aurexoul/public_html/jacob/wp-includes/class-snoopy.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/aurexoul/public_html/jacob/wp-includes/rss-functions.php on line 370

    My site is at http://jacob.aurexoul.com/

  2. dss
    Posted 11 years ago #

    I can't find any wordpress related rss feed on your site.

    not the /feed permalink
    nor the wp-rss2.php


    try swapping the theme to the default and let'scheck again?

  3. Jacob
    Posted 11 years ago #

    I switched over to the default theme. The error still shows up in the Admin area.

  4. dss
    Posted 11 years ago #

    Ok, but it's a little different on this end:


    come back blank now, not "error"

    but you are still getting 404 on the "/feed" page.

    I'm no expert, but i suggest this:

    0. check to be sure you're not blocking stuff with wonky permissions.

    if everything checks out then:

    1. reinstall 1.5.1

    delete the files, and then re uplod them.
    use a fresh download of the script.

    run the update.php again too.

    2. perform this modification:

    a.) the rss fix

  5. dss
    Posted 11 years ago #


    be sure your .htaccess file is writable and update your permalink structure.

    then post something. anything new since the re install.

    these are all the things i've done to get 8-9 installs of 1.5.1 working just fine (as far as i can tell.)

  6. Jacob
    Posted 11 years ago #

    I will try it out tomarrow. I have to get off now. Thanks for your help. I'll post if I figure it out or if I need more guidence. :)

  7. dss
    Posted 11 years ago #

    hope it works out.


  8. Jacob
    Posted 11 years ago #

    Thanks. :) It worked!! My Dashboard is working again, and I think that my Feeds are alive also.

Topic Closed

This topic has been closed to new replies.

About this Topic