Support » Installing WordPress » Dashboard empty after clean install of 2.8

  • I get empty dashboard after a clean new install of latest wordpress version (2.8) on my ubuntu server (I installed it from the same latest.zip on windows locally and it worked fine.)

    Dashboard appears only after the first login, with the “change your initial password” message, but on any click or login after that it’s just an empty page.

    I tried some solutions I found here, but deleting all plugins (meaning akismet and dolly, since it’s clean install) or increasing memory limit in both php and wordpress configs to 64M doesn’t help, and there is nothing at all in php error log.

    I’ve commented call_user_func line in do_meta_boxes function in wp-admin/includes/template.php so I can login to my admin, but that removes the content of dashboard widgets, leaving me only with the menu.

    It’s better than completely empty dashboard, but I’d like to have some dashboard widgets… any ideas?

    Is there anything I need to install or uninstall on the server or change anything in the server configuration (I can do it, it’s mine 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • whooami

    (@whooami)

    Member

    ok, so what does your apache error_log say?

    It says nothing related to blog folder

    whooami

    (@whooami)

    Member

    are you logging PHP errors?

    Ive never seen an apache install with proper error logging set up that didnt work to debug these sorts of things.

    Yes… I checked it, php error log works fine for all other errors on the site, but there are no errors from wordpress folder. I even made an intentional error in template.php just to see, but that error got logged ok.

    I noticed this issue too, and saw nothing reported in the apache error.log for the vhost that had the issue, however I realised I have another log file for apache, and discovered this:-

    alan@bishop:/var/log/apache2$ ps -ef > ~/pslist

    (then visit the wp-admin dashboard)

    alan@bishop:/var/log/apache2$ sudo tail -n 1 error.log
    [Thu Jul 02 00:58:30 2009] [notice] child pid 31251 exit signal Segmentation fault (11)

    alan@bishop:/var/log/apache2$ grep 31251 ~/pslist
    www-data 31251 5012 0 00:58 ? 00:00:00 /usr/sbin/apache2 -k start

    So it looks like apache itself is crashing. Just thought I’d mention that. Time for me to go to sleep so I’ll have to look at tuning Apache in the morning.

    Any luck so far?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Dashboard empty after clean install of 2.8’ is closed to new replies.