• Resolved Lightpurple



    I have started adding members and logging in with their accounts to make posts. I have read your video http://docs.wedevs.com/wp-user-frontend-pro/#post-editing
    and the following thread http://wedevs.com/support/topic/dashboard-edit-link-missing/.

    1. I have created posts linked to the WPUF form dropdown.
    2. I have selected the appropriate page with the [wpuf_edit] shortcode under ‘General Options’.
    3. I have added the separate ‘Dashboard’ page with the shortcode.

    However, I am still unable to see the ‘Edit’ link in the ‘Dashboard’ when logged in as a user (even when logged in as admin). I noticed that in the thread stated above, that I should be able to click on the ‘Dashboard’, ‘Profile’, ‘Payments’, etc. tabs on the ‘User Frontend’ settings tab. But when I click on those tabs, nothing happens. It doesn’t change from the ‘General Options’ tab.

    Is the plugin installed correctly or should there be something else I should be doing? I am happy to provide a user login if needed.

    Thanks in advance.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello..

    Can anyone help on this? I still can’t get this to work.

    Thanks in advance.

    Plugin Author Tareq Hasan


    Saving the plugin settings again should solve the problem.

    Its simple,

    open wpuf-dashboard.php in wpuf plugin folder

    replace this line

    <a href="<?php echo get_edit_post_link( $id, $context ); ?>"><?php _e( 'Edit', 'wpuf' ); ?></a>

    instead of this (line: 162)
    <a href="<?php echo wp_nonce_url( $url . '?pid=' . $post->ID, 'wpuf_edit' ); ?>"><?php _e( 'Edit', 'wpuf' ); ?></a>

    You just update the href link.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Dashboard Edit Link Missing’ is closed to new replies.