Support » Fixing WordPress » Dashboard Doesn't Load Now Getting Fatal Error Message

  • Howdy,

    Site was updated to 3.8 automatically and now my dashboard won’t load. I can log-in but the dashboard is completely blank. After some googling I found that if I renamed the theme folder to “theme-temp” it may fix the issue.
    So I went ahead and did that and got this error:

    Fatal error: Call to undefined function wp_register_plugin_realpath() in /hermes/bosoraweb066/b370/glo.mimmiroo/wp-settings.php on line 213

    I’ve since renamed the folder to the original name and I’m still getting the above error.

    Any advice?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Remove “wp-settings.php”,and reuprord new one from buckup
    I recovered my website that way

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Have you tried:

    • flushing any caching plugins you might be running, as well as server and/or browser caches.
    • deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read “How to deactivate all plugins when you can’t log in to wp-admin” if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old
    • switching to the Twenty Fourteen theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twenty fourteen. That will force your site to use it.
    • manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.5 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first.

    Just an update on where I’m at with the issue:

    I’ve deactivated all plug-ins and reverted back to the Twenty Fourteen theme. I got the dashboard back, and was able to re-install my original theme. However, whenever I activate any plug-in ( I’ve done it one by one and have run into the same issue with all plug-ins) I get the Fatal Error message.

    I’ve held off on upgrading to 3.9 for now. The company that built the framework theme I’m using suggests not upgrading until they’ve checked for compatibility.

    Is there anything I can do to get my plug-ins back?

    I’ve been having the same issue as DesignerRoo. I just updated my site to 3.8 and now I can’t even go from one admin section to another (ie – from Posts to Pages) without getting the Fatal Error message.

    How would I go about fixing this?

    I encountered the same problem. After some investigation turns out that the function wp_register_plugin_realpath() isn’t specified in /wp-includes/plugin.php.
    So I copied the WP 4.0 Beta version of plugin.php from GitHub and replaced it with the current one. Now at least I can reactivate my plugins again. Don’t know of any side effects yet. Please first make a duplicate of your existing plugin.php before updating.

    Hi all,

    I’m not sure if this counts as a solution but I backed up my wordpress theme & content and just upgraded to 3.9
    So far so good, plugs-ins work and the theme is being displayed. The only issue I had was that when I tried importing my content only a select few made it – this could be error on my part. It’s not as big of an issue as not accessing my dashboard & plugins, so it works for me.

    So this happened on one of my sites, but I can’t even log in to the back end at all. I’ve tried uploading a new copy of plugin.php, but this didn’t work.
    Does anyone have any other suggestions? I cannot find any information about this.

    Thank you yumehiro0811
    Replacing the wp-settings.php with another from a backup worked for me!!!
    Replacing plugin.php with the WP4 beta didn’t worked.

    tsheridan,
    Enter via FTP to wp-contents/plugins/ and change all plugin’s folder names, for example add an x at the end, this will de-activate the plugins until you do the first part.

    Regards

    Thanks Tekman, I’m half way there! I got in, but can’t get anywhere. As soon as I try to activate a plugin, or click around anywhere, either in the front end or back end, I get the same error message again.
    Sure could use some help, if anyone has any more suggestions. I’m stumped!

    Well, after all I’ve had to replace all the wp-admin and wp-includes folder (downgrade WP) now it seems good but I’ll see what happened…

    keep me posted to update my results…

    Regards,

    Fatal error: Class ‘WC_Shipping_Method’ not found in /home/content/57/12342357/html/wp-content/plugins/synmedia-woocommerce-shipping-ups/classes/class-wc-shipping-ups.php on line 7

    I am getting this message when I log in. I do not have the dashboard that area is totally blank. I have no idea what I am doing. Can anyone help me fix the problem?

    I can not even access my editor page.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Dashboard Doesn't Load Now Getting Fatal Error Message’ is closed to new replies.