Support » Fixing WordPress » Dashboard Borked

  • I just upgraded to v2.2 using the 5-step method and my dashboard is borked. It shows the blog behind the dashboard. I tried deleted the wp-admin folder and re-uploading it but to no success. Here’s a link to show you what I’m talking about


Viewing 14 replies - 1 through 14 (of 14 total)
  • Clear your cache?

    I tried that, but still the problem persists.

    I too am experiencing this problem.

    The dashboard looks fine but once the page finishes loading the incominglinks div and the devnews div both seam to load the entire blog homepage into their div, very weird.


    I get the same crap! Does anyone know how to fix this ?




    oke, try this:

    IF YOU DO NOT HAVE an .htaccess in your wp-admin/ directory:

    create a text file on your desktop:

    put the following inside it, on the top line:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    save the file.

    Upload the file to your wp-admin directory.

    Rename the uploaded file to .htaccess (with the .)

    IF YOU DO HAVE an .htaccess in your wp-admin/ directory:

    Edit it:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    save the new .htaccess

    Post back if that helps.

    Correct me if I’m wrong, but if you have “SecFilterInheritance Off” doesn’t it lower your security and open some holes for exploits and vulnerabilities?

    Thanks whooami,
    Worked for me, but should kingv’s post concern me?

    whooami or anyone else,

    can you let us know if this is true?


    I’m not sure what other posts I read, but somehow now I get just the 404 Forbidden messages where the dev news usually shows up and on the right column where incoming links are. I tried editing my .htaccess but I would always get a 500 Internal Server error. I followed the instructions on some of the other posts, but still I can’t seem to figure out the best solution. Kinda frustrating since I usually never have upgrade problems, but at least it doesn’t look like it did in my original post anymore.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Correct me if I’m wrong, but if you have “SecFilterInheritance Off” doesn’t it lower your security and open some holes for exploits and vulnerabilities?

    If mod_security provided any kind of actual security, then yes, you would be correct. But the truth of the matter is that mod_security is, generally, crap. The idea is fine, but the rules that it uses to block things are generally silly and get in your way more than they protect you from anything.

    Security is not a magic bullet. Even with mod_security, it’s possible for you to be compromised.

    If you’re worried about it, make an .htaccess with that security disabling thing in the /wp-admin directory only. That will disable it, but only for that directory.

    hey this worked for me in sorting out my screwy dashboard, but ALSO helped this problem:
    cheers! 🙂

    I must have some kind of server specific setup because I just upgraded to 2.2.1 and experienced the same wp-admin problem. I tried the .htaccess solution and I only get a 500 Internal Service Error. The only way to unbork is to remove

    <script type="text/javascript">
    Event.observe( window, 'load', dashboard_init, false );
    function dashboard_init() {
    	var update1 = new Ajax.Updater( 'incominglinks', 'index-extra.php?jax=incominglinks' );
    	var update2 = new Ajax.Updater( 'devnews', 'index-extra.php?jax=devnews' );
    	var update3 = new Ajax.Updater( 'planetnews', 'index-extra.php?jax=planetnews'	);

    from my wp-admin/index.php

    I did the things with the .htaccess file as suggested, but it was not until I made two changes under options. Change both URL addresses to https://

    This is because I am running WP under a secured site. Only make this change if you are running on an https site.

    Once I changed the URL the problem was resolved. The .htaccess may have helped too.

    See our site at, click the left sidebar option “Delightful Diablogue”

    Thanks for your help everyone!

    🙁 darn, the .htaccess fix doesn’t work for me… any other ideas

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Dashboard Borked’ is closed to new replies.