Support » Fixing WordPress » Dashboard Ajax saving suddenly not working

  • Resolved Jon Fergus

    (@jon-fergus)


    While I was updating some theme options (i.e. midway through an ajax save command) my internet connection was interrupted. When it came back, I’m suddenly not able to save anything that does so through ajax. Options that require page reload do save, but options that don’t require page reload don’t save.

    So, for instance, if I use the customizer and try to add custom css, I press “publish” and it shows as though it has published. But when I reload the page, the css code I had entered is gone (i.e. the saving didn’t actually work). Same goes for saving theme options (Avada theme) which uses ajax, so it tells me that my options have been changed, but when I reload it shows the changes didn’t save.

    I have changed nothing else in my setup. This inability to save happened immediately after the internet disruption, so it isn’t an issue with incompatible plugins or theme issues or whatnot. Everything was fine, then suddenly ajax saving is somehow disabled.

    I have absolutely no idea how to fix this, but I’m basically dead in the water right now. Need some help asap.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I speculate that losing and then reconnecting your internet connection somehow disrupted the “session” you had established between your browser and webserver.

    Suggest that you logout and then login again, maybe you have already done this in which case I have no idea.

    Thread Starter Jon Fergus

    (@jon-fergus)

    Nope. That’s not it. I’ve tried logging out and back in. Tried multiple browsers. All the same result.

    Thread Starter Jon Fergus

    (@jon-fergus)

    Update: spent some time working on it with our host (Dreamhost). The issue exists on both our main domain and our dev sub-domain (where I first noticed the issue), so it isn’t restricted to a single wp install. There is another subdomain on this same site, and it does not exhibit this issue. The two sites where the issue is present are running php 7.4, the other is running 7.2. Still haven’t solved the issue, but wanted to add this here for anyone else who may want to reply.

    Thread Starter Jon Fergus

    (@jon-fergus)

    Found the culprit. A single unicode character added as ‘content’ in the css code was somehow messing things up. Bizarre.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Dashboard Ajax saving suddenly not working’ is closed to new replies.