Support » Fixing WordPress » (Problem with) sitemap!

  • What a pain…

    this..

    /wp-sitemap.xml

    I have it on V 5.4.2 and 5.5

    I add the filter to remove it in functions.php and it doesnt go away. How do I remove this URL?

    • This topic was modified 1 year, 5 months ago by Yui. Reason: renamed topic
Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Yui

    (@fierevere)

    ゆい

    See:

    New XML Sitemaps Functionality in WordPress 5.5


    FAQ for plugin: https:///wordpress.org/plugins/core-sitemaps/

    there are filters to tune or completely disable new sitemap functionality.

    Thread Starter omris83

    (@omris83)

    I had, and using the filter doesnt get rid of the URL.

    The filter should stop it from creating another sitemap.xml. The sitemap has already been created though so that must be still showing.

    Do you have anything else creating a sitemap? I’m asking as a sitemap is usually a good thing but you don’t want multiple sitemaps being generated and confusing things.

    Anyway, In Dashboard –> Settings –> Reading at the bottom is a checkbox to discourage search engines from crawling your site. I was told that checkbox turns that off completely as it suppresses that output so…

    This is just my best guess here but, would you check that, save the settings, then check to see if it’s gone?

    I’d try that here but the only site I have 5.5 running on is a multisite where every site there has the ‘discourage’ option already set.

    If that rids your site of the wp sitemap.xml then uncheck that again and check to see if it comes back. Check for it a few times over the next hour if you would. I want to make very sure cron doesn’t put it back later.

    It would be very helpful if you would let me know either way that goes so we might help others with the same type problems or further pursue this if the file comes back.

    Thread Starter omris83

    (@omris83)

    Telling search engines not to index doesnt really help, but even with testing its still there.

    Its throwing out a lot of code which looks like WP Bakery. The issue lies either with them or WP. Not sure at this stage.

    I use AIO SEO to create my sitemap which as Ive learned in default, adds that filter in so something very strange going on here.

    Hi @omris83,

    This code snippet will disable the new sitemaps feature:

    add_filter( 'wp_sitemaps_enabled', '__return_false' );

    However, many SEO plugins have implemented their own filter for this, and could potentially be overriding any filter you add. The SEO plugin authors are using the filters added to WordPress to modify and manipulate the generated sitemap according to settings and features found in their plugins.

    It seems like a support topic in the AIO SEO forum, and reaching out to the WP Bakery folks would be better to resolve your issues.

    Another important clarification is that an actual sitemap.xml file is never created, so there is nothing to delete.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘(Problem with) sitemap!’ is closed to new replies.