Support » Plugin: iThemes Security (formerly Better WP Security) » Daily Security Digest email changed language after updating to WordPress 4.7

  • Leandro

    (@leandroprz)


    After updating to WordPress v4.7 and changing the language to English (United States) on my admin user profile (I want the dashboard in that language), I started getting the Daily Security Digest emails in Spanish, which is the language I have for the whole frontend and it’s the language I have in WordPress’ General Settings.

    Plus, the whole iThemes Security dashboard is now in Spanish and since I chose English for my profile, shouldn’t it be in English?

    Is there a way to change the Daily Security Digest email back to English?

    I’m using iThemes Security v5.9.0.

    Thank you

    • This topic was modified 1 year ago by  Leandro.
    • This topic was modified 1 year ago by  Leandro. Reason: More information
Viewing 9 replies - 1 through 9 (of 9 total)
  • pronl

    (@pronl)

    @leandroprz

    I’m confused. Please describe the 3 situations by completing the schema below:

    WordPress 4.6.1 (previous situation)
    WP Dashboard – General Settings Sitelanguage = Spanish

    WP Dashboard –> ?
    DSD email –> English
    iTSec Dashboard –> ?

    –//–

    WordPress 4.7 (current situation)
    WP Dashboard – General Settings Sitelanguage = Spanish
    Admin user profile Language = Site Default –> English (United States)

    WP Dashboard –> ?
    DSD email –> Spanish
    iTSec Dashboard –> Spanish

    –//–

    WordPress 4.7 (expected situation)
    WP Dashboard – General Settings Sitelanguage = Spanish
    Admin user profile Language = Site Default –> English (United States)

    WP Dashboard –> English
    DSD email –> English
    iTSec Dashboard –> English

    Leandro

    (@leandroprz)

    Sorry for the confusion, English isn’t my native language.

    WordPress 4.6.1 (previous situation)
    WP Dashboard – General Settings Sitelanguage = Spanish

    WP Dashboard –> Spanish
    DSD email –> English
    iTSec Dashboard –> English

    –//–

    WordPress 4.7 (current situation)
    WP Dashboard – General Settings Sitelanguage = Spanish
    Admin user profile Language = Site Default –> English (United States)

    WP Dashboard –> English (United States)
    DSD email –> Spanish
    iTSec Dashboard –> Spanish

    –//–

    WordPress 4.7 (expected situation) – This is correct, but not happening
    WP Dashboard – General Settings Sitelanguage = Spanish
    Admin user profile Language = Site Default –> English (United States)

    WP Dashboard –> English
    DSD email –> English
    iTSec Dashboard –> English

    • This reply was modified 1 year ago by  Leandro.
    pronl

    (@pronl)

    @leandroprz

    Ok, I see.

    Looks like even though iThemes states the iTSec plugin supports WP 4.5 up to 4.7 they probably haven’t made the necessary changes to support the user profile Language setting which was introduced in WordPress 4.7 …

    What happens when you temporarily rename the better-wp-security-es_ES.mo and better-wp-security-es_ES.po files in the wp-content\languages\plugins folder (if these files exist) ?

    Leandro

    (@leandroprz)

    Renaming the files makes the plugin show up in English.

    And now I got a new update about some translations, I’m pretty sure it’s about this plugin.

    • This reply was modified 1 year ago by  Leandro.
    pronl

    (@pronl)

    @leandroprz

    Ok, that makes sense.

    Renaming the Spanish iTSec plugin .mo and .po files is just a workaround.
    As a side effect the workaround indeed will trigger a new translation update notification.
    Accepting the translation update will probably undo the workaround.

    Anyway in short this topic is a bug in the iTSec plugin.
    Basically the iTSec plugin translation is loaded too early (before the user is initialized). So it picks up the Admin user profile Language (fallback) value which is the Site Language (es_ES) …

    More (developer) info about this new 4.7 feature is available in this article.

    Leandro

    (@leandroprz)

    I just noticed the workaround stops working after a few hours because WordPress automatically update the translations. So I guess this is a bug for the developer of the plugin to fix.

    • This reply was modified 1 year ago by  Leandro.
    pronl

    (@pronl)

    @leandroprz

    Yep, this is a bug that iThemes needs to fix.
    I’m sorry to hear the WordPress auto update mechanism sabotages the workaround.
    However it is possible to disable plugin specific translation updates.

    You can find a code example for this here (for BuddyPress plugin).
    Only needs a small change and you can use that code for the iTSec plugin.

    Leandro

    (@leandroprz)

    Thanks!

    I just added that code (modified to suit the plugin) to my functions file (a plugin with a buch of code for different stuff). I see the update is still available in the Updates page in my WordPress dashboard, hopefully it won’t auto update the translation.

    Well, this isn’t a permanent solution. Updating a different plugin automatically updates any translation left inside the Updates page.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Daily Security Digest email changed language after updating to WordPress 4.7’ is closed to new replies.