Support » Plugin: UpdraftPlus WordPress Backup Plugin » Daily backups are not working

  • Resolved agb58

    (@agb58)


    For some reason, in one of my sites that I have UpdraftPlus installed, the backups are not working. In all my other sites, which I have the same configuration, these backups are working fine.

    This is the thing. I have set up Daily backups and a maximum of 7. I have disabled WP_CRON in wp-config.php file and I have setup a cron to run every day (for wp-cron.php). While in the other sites, it is working fine, in this particular site, the backups are not working and I have no clue why.

    The backup system I am using is Google Drive.

    Is there a way to debug why the backups are not working and see the cause of the problem? Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • agb58

    (@agb58)

    By the way, I see a message on my Updraft config that says:

    Warning: WordPress has (19) scheduled tasks without executing. Unless this is a development site, this probably means that your WordPress programmer is not working.

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    Please could you send us a copy of the latest backup log? This can be found in the UpdraftPlus Existing Backups tab.

    The contents will be too long to post here directly, but you can use an online service such as Dropbox or Pastebin, and post the link here.

    Best Wishes,
    Bryle

    agb58

    (@agb58)

    Hey Bryle, here you have it: https://pastebin.com/RARf3HHX

    I have replaced the confidential info with generic info.

    agb58

    (@agb58)

    @bcrodua any clue on why it is not working?

    agb58

    (@agb58)

    Hey @bcrodua it is still not working. We currently need to do the backups manually which is not ideal. Did you have a chance to review the log file?

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    The backup in the log appears to have been completely successful. Do you have a log of a failed backup?

    David

    Here you have it @davidanderson

    0000.000 (1) Opened log file at time: Mon, 18 Feb 2019 23:00:04 +0000 on http://website.com

    0000.010 (1) UpdraftPlus WordPress backup plugin (https://updraftplus.com): 1.16.6 WP: 5.0.3 PHP: 5.6.38 (cli, Linux my.server.url 3.10.0-862.14.4.el7.x86_64 #1 SMP Wed Sep 26 15:12:11 UTC 2018 x86_64) MySQL: 10.2.18-MariaDB WPLANG: es_ES Server: safe_mode: 0 max_execution_time: 900 memory_limit: 512M (used: 47.2M | 48M) multisite: N openssl: OpenSSL 1.0.2k-fips 26 Jan 2017 mcrypt: Y LANG: es_ES.UTF-8 ZipArchive::addFile: Y

    0000.013 (1) Free space on disk containing Updraft’s temporary directory: 11015.4 MB

    0000.024 (1) This backup task (5a8097b6b4f8) is either complete or began over 2 days ago: ending (1550530804.8322, ) (existing jobdata keys: )

    • This reply was modified 4 weeks, 1 day ago by  agb58.
    • This reply was modified 4 weeks, 1 day ago by  agb58.
    • This reply was modified 4 weeks, 1 day ago by  agb58.
    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    From the logs, it appears that your custom cron schedule may not be triggering the scheduler often enough.

    How often is the cron setup set to run?
    It is usually recommended to run wp-cron every 5 to 10 minutes. UpdraftPlus is designed to trigger a resumption of the backup process every 5 minutes, via the scheduler.

    If the cron job is only run once a day, then the backups may display the errors that you are seeing, where scheduled tasks are attempted long after their intended time.

    I have set up wp-cron to run once per day because that is enough, for all my sites. However, I don’t know why, this site is not performing as the other ones, as it has the same configuration.

    Running wp-cron every 5 minutes is not efficient and it slows down the sites. There should be a better way to fix this issue. And even though I can set up the wp-cron like that, it should not fail in the first attempt.

    Plugin Author David Anderson

    (@davidanderson)

    That’s a common misunderstanding about wp-cron, but isn’t actually the case. I speak as someone who’s a contributor to WP core in this area.

    Running wp-cron more often instead of less often doesn’t slow down anything unless there’s something seriously wrong with the web hosting. Scheduled tasks take exactly the same amount of time to run, whatever mechanism they’re run by…. the only way they can take up less resources is if they’re not run at all, i.e. if you effectively disable that part of WP (but in that case, things inside WP will break).

    David

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.