Support » Plugin: Blazing Charts » D3 Library Revision

  • Resolved mshu

    (@mshu)


    Hi Massoud,

    Thanks for the great plug-in. Which revision of the D3 library is loaded by blazingcharts? Is there an option to select a different library revision?

    I loaded D3.v4 with <script src=”//d3js.org/d3.v4.min.js”> in the header, but receive “d3.scaleLinear is not a a function” error on the console. In changing from v3 to v4, the d3.scale.linear function was replaced by d3.scaleLinear. Is an older library being used?

    Outside of the WP and blazingcharts environment, my html, css and js is working as expected.

    Thank you in advance!

    • This topic was modified 2 years, 8 months ago by mshu.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Massoud Shakeri

    (@massoudshakeri)

    thanks. I think it’s 3.5
    If you don’t need this plugin to load D3 for you, you can give a shortcode like following:
    [BlazingChart source=”your-snippet”]
    just remove charttype=”d3”, so it does not load it twice.

    Thread Starter mshu

    (@mshu)

    Thanks for the quick response. v3.5 must be loading on top of 4.13.0 which is confirmed to be loaded at the top of the script, even in the WP environment. Your suggestion of not specifying charttype fixed the issue. Many thanks for your plug-in and great support!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘D3 Library Revision’ is closed to new replies.