Support » Plugin: Auto Image Attributes From Filename With Bulk Updater » Cyrillic image name = the 1st word is missing

  • catshands

    (@catshands)


    When file name starts from a Cyrillic letter, the plugin misses the whole 1st word.
    While using with classic editor, where image title is generated by WordPress itself, everything is fine. But if I chose to generate the title, alt, etc by your plugin, it misses the 1st word.
    Interesting: adding a single English letter to the beginning of the 1st word solivng the problem.
    Example: File name = “Высокое дерево” -> alt = “дерево”, but file name = “wВысокое дерево” -> alt = “wВысокое дерево”
    Any ideas how to fix?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Arun Basil Lal

    (@arunbasillal)

    Hello @catshands

    Thanks for checking out my plugin and sorry for the delay in getting back to you.

    I tested this out and wasn’t able to replicate this at my end. I am wondering if this is something similar to what I reported here: https://wordpress.org/support/topic/not-good-cyrillic-names/#post-11612241

    Here is a screenshare – https://jmp.sh/1OI2mMv
    Similar results with Classic editor as well – https://jmp.sh/q4Zfgwc

    Can you please take a look at my reply in the link to the other discussion and see if that addresses this problem. I am very curious why this is happening. Would love to improve it for everyone.

    Thanks.

    Thanks for the answer.
    To tell the truth, I afraid to play with locales coz the site is pretty popular and there might be unexpected results for some platforms/browsers.
    I see that you extract names for alt attributs from the URL. Is it possible to get it from the title generated by WordPress itself? Coz seems like WordPress doesn’t have problems with generating titles form filename with any locale settings.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.